jump to last post 1-3 of 3 discussions (19 posts)

Hub ratings count not real time

  1. Glenn Stok profile image99
    Glenn Stokposted 5 years ago

    It seems that there is a problem saving incremented vote counts for
    Useful, Funny, Awesome, Beautiful, or Interesting


    I have discovered that votes return to their prior value when I return to a Hub after voting.

    It shows up as incremented. But then goes back to the prior setting after leaving the page.

    I tested this with the following browsers. Same results with each...

    Safari on Apple iPad iOS 5.1.1

    And on Windows XP with ...

    Firefox 13.0.1

    IE 8.0.6001.18702

    Chrome 19.0.1084.56 m


    There is no way for me to know if thumbs up and down has the same problem. But that should be checked out too.

    1. paradigmsearch profile image86
      paradigmsearchposted 5 years ago in reply to this

      That's happened to me in the past as well. The incrementation will show up the next day. Leastwise they have for me so far. big_smile

      1. Glenn Stok profile image99
        Glenn Stokposted 5 years ago in reply to this

        I thought of that too. Some changes take time to register, such as adding new tags. So I thought that might be the case with votes. But today I looked at one I voted on a few days ago. It's back to the previous value.

    2. Matthew Meyer profile image79
      Matthew Meyerposted 5 years ago in reply to this

      @Glenn

      Thanks for the info.  I will see if I can repeat the issue and then get this sent to the engineering team to be addressed.

    3. Matthew Meyer profile image79
      Matthew Meyerposted 5 years ago in reply to this

      @Glenn I reproduced this issue in Internet Explorer 9 in Windows 7.

      I have sent the details to our engineering team to be addressed.

      Thanks for bringing this to our attention and thanks for documenting it so well!

      1. Glenn Stok profile image99
        Glenn Stokposted 5 years ago in reply to this

        Matthew, thank you or following up on this. I'm glad you were able to reproduce it too. At least now I know that I haven't been going crazy.

  2. Glenn Stok profile image99
    Glenn Stokposted 5 years ago

    Funny thing is, I just took a look at one of my Hubs and it has incrementing votes. So obviously other people can vote. But my votes on other Hubber's Hubs don't seem to register.

    1. paradigmsearch profile image86
      paradigmsearchposted 5 years ago in reply to this

      I dropped by your profile to give one of you hub's buttons my regards. big_smile

      That topic menu on your profile page is awesome!!! It never occurred to me that we could do that.

      1. Glenn Stok profile image99
        Glenn Stokposted 5 years ago in reply to this

        Thanks for the complement, paradigmsearch. Unfortunately once HP implements the new profile format next month I won't be able to have that list anymore. I think I read somewhere that they are doing away with allowing hyperlinks in the profile text. I could be wrong. But as I understand it (also from something I read), we'll have more control over the "featured Hubs" list.

        Let me know if your vote increments.

        1. paradigmsearch profile image86
          paradigmsearchposted 5 years ago in reply to this

          Awesome {3} • Beautiful {1} • Interesting {5}

          So far, it has not. It should be

          Awesome {4} • Beautiful {2} • Interesting {6}

          on your newest hub.

          1. Glenn Stok profile image99
            Glenn Stokposted 5 years ago in reply to this

            Funny {12} on the one about Hell Freezing over. But went back to 11.

            Let's give both of these 24 hours and see what happens.

            1. paradigmsearch profile image86
              paradigmsearchposted 5 years ago in reply to this

              Interesting. My clicks on your hub have updated. Your click on mine has not. You are right.

              1. Glenn Stok profile image99
                Glenn Stokposted 5 years ago in reply to this

                Interesting. I wonder if it might have anything to do with a particular setting of options that I have selected in my account. It would be interesting to know if this is happening to anyone else. The only way to know, is if others would keep track of the vote counts after voting and then go back and look later.

                I have read a good number of great hubs that I had voted on and I feel bad that my votes don't register. I hope HP can figure this out and fix it soon.

                1. paradigmsearch profile image86
                  paradigmsearchposted 5 years ago in reply to this

                  I did some research. Whenever someone has 777 followers, HP disables their button-clicking capability. It's in the TOS.

                  1. Glenn Stok profile image99
                    Glenn Stokposted 5 years ago in reply to this

                    I thought things get screwy when we reach 666.  lol

  3. Glenn Stok profile image99
    Glenn Stokposted 5 years ago

    paradigmsearch, 

    I see my votes remained in some hubs but not all. However it is possible that someone else voted so I can't be sure those values are from my last votes.

    My vote in your hub went back to the prior value. So I tried again today. Should be as follows...

    Useful  • Funny (undo) {12} • Awesome {1} • Beautiful  • Interesting (undo) {1}

    I hope HP is reviewing this bug report.

    1. Matthew Meyer profile image79
      Matthew Meyerposted 5 years ago in reply to this

      @Glenn  I got a response from our engineering team.
      We do not process and record ratings in real time.

      Any rating will indicate an increment when clicked, but those ratings are not committed until later.  We merely show the number increase as a visual indicator that something has occurred.

      We also have logic to disregard duplicates from the same user or ip address, so a vote is not recorded multiple times.

      So the information is being captured, just not applied in real time.

      1. Glenn Stok profile image99
        Glenn Stokposted 5 years ago in reply to this

        Matthew, I have to disagree with the conclusion.  I have monitored my new votes and after 24 and even 48 hours, it still does not show up. Follow the thread with the experiment I did with paradigmsearch.

        These are definitely first time votes and not duplicates. Except for the test with him where the counts went back to the previous setting. And I tried voting again after a couple of days. In no case did I vote twice on any other hub.

        Please have your engineering dept review my own IP address and see if they can find where I voted twice on the same hub. I am sure they will not find any.  This IS a real problem.  I cannot vote on any new hub that I am reading lately.

Closed to reply
 
working