jump to last post 1-7 of 7 discussions (9 posts)

Help! How come I don't see my images?

  1. kidsandcrafts profile image61
    kidsandcraftsposted 4 years ago

    Hi,
    I am new to this and I'm sort of frustrated sad I'm finding that Hubpages isn't very user friendly. I uploaded a picture for my background, it showed up in the small square on my set up page and on my profile page and now it's gone! I also tried to upload an image so I could complete my first hub...it showed up and then disappeared. Does anyone know where they went and how I can get them back. Obviously I'm doing something wrong. The images have the proper pixels and they were successfully uploaded but they didn't last long.
    Any help would be greatly appreciated!
    Thanks in advance!
    Jennifer

  2. KDeus profile image95
    KDeusposted 4 years ago

    Hi Jennifer, I've had that happen a few times and it was driving me batty. I ended up doing a hard refresh on the browser with <CTRL><F5> and it worked. Hopefully that will work for you. Even if it doesn't, the image is still there - at least I found in my experience.

    1. kidsandcrafts profile image61
      kidsandcraftsposted 4 years ago in reply to this

      Thanks so much for your help! I'm going to try it now!!!

  3. expertscolumn profile image81
    expertscolumnposted 4 years ago

    Hi there Jen,
    If you upload a picture for your background and do not see an immediate change, just give it time. I've seen it where my background only took effect after a day.

    Same with hub photo uploads, this is because the hubpages server has to process the image. If they don't appear right away they will appear within a day.

    I understand your frustration usually when I write a hub and add a image I re-upload again and again and usually the second or third time, it loads up.

    If you go to http://hubpages.com/my/photos/gallery you will find all your photos, including photos you may have reuploaded many times because it didn't appear right away.

    Hope that helps

  4. kidsandcrafts profile image61
    kidsandcraftsposted 4 years ago

    Thank you! I checked my page this morning and there was my background! I also went to my photo gallery as you suggested and saw my gazillion attempts! Oh boy!
    Once my first hub is published and everyone can see my page, will they also be able to view the photos in my gallery? I thought about dumping a bunch of photos there to be used later but I don't want them viewed until I'm ready for them.
    Thanks for your help...looks like I'm going to have to exercise a little patience smile
    Take care,
    Jennifer

    1. KDeus profile image95
      KDeusposted 4 years ago in reply to this

      Glad to hear that they finally appeared! Welcome to hubpages!

  5. Jeff Berndt profile image92
    Jeff Berndtposted 4 years ago

    I noticed the same thing this morning. It's not just you. Luckily, turns out it's a sporadic thing, and as others have mentioned, if you refresh your page, the images will probably appear.

    Welcome to HubPages!

  6. HattieMattieMae profile image68
    HattieMattieMaeposted 4 years ago

    They show up eventually, I have that happen quite a lot. I just up load them, and when the website decides to stop freaking out, they show up. lol

  7. expertscolumn profile image81
    expertscolumnposted 4 years ago

    Hi there again,
    To the best of my knowledge a visitor can only see the photos you place in that particular hub page, they can't see your gallery. Only you can,


    Welcome to hubpages.

 
working