jump to last post 1-6 of 6 discussions (21 posts)

Broken links

  1. bravewarrior profile image93
    bravewarriorposted 2 years ago

    For a couple of weeks now, when I go into my account, one of my hubs is showing a broken link. However, every time I go into it, there's nothing highlighted, nor is there a cross-thru on a link when I'm not in edit mode. I was thinking this is an HP glitch, but too much time has gone by now for that to be the case.

    Or is it a glitch-in-reverse? What I mean by that is, has my hub been marked incorrectly?

    Has anyone else run into this problem?

    Will an HP moderator please come in and help me out?

    1. sallybea profile image96
      sallybeaposted 2 years ago in reply to this

      The broken link could be an Amazon Ad or an image.  Look below each of your images to see if there is one which has blue writing underneath.

      1. bravewarrior profile image93
        bravewarriorposted 2 years ago in reply to this

        Sally, I've done that. I'm all to familiar with how HP flags/highlights broken links and for the life of me, I cannot find what they are referring to in this particular hub.

    2. Matthew Meyer profile image78
      Matthew Meyerposted 2 years ago in reply to this

      There is a known issue with some broken links not being highlighted.
      It affects the optional photo source (URL) field in photo capsules.
      You can find more information in this thread.
      http://hubpages.com/forum/post/2713316

      The broken links page will list the URL.
      http://hubpages.com/my/hubs/broken-links

      1. sallybea profile image96
        sallybeaposted 2 years ago in reply to this

        Thanks Matthew that is helpful.

      2. bravewarrior profile image93
        bravewarriorposted 2 years ago in reply to this

        Thanx for being so quick to respond, Matthew. I'll test the links myself and see what is failing.

        Will this glitch be remedied soon? I don't check my account page daily, but when I do, I try to address any issues at hand.

    3. csmiravite-blogs profile image86
      csmiravite-blogsposted 2 years ago in reply to this

      Nope. If it says broken link, I can always find where the problem is and change it to another link that works. If not, I may need to review all the links and see which doesn't work

  2. LindaSmith1 profile image60
    LindaSmith1posted 2 years ago

    Test all of your links to see if they are working. I know when you do a text link, and leave on / or omit one thing of the url, it makes it a broken link. I have done this a few times.

    1. bravewarrior profile image93
      bravewarriorposted 2 years ago in reply to this

      Linda, I'll try that. I don't have any links in the text - just photos. This is the second chapter of a novel I was posting, so I didn't have any of my own photos to post (which I try to do whenever possible).

      Thanx for the reminder. I should have thought of that myself.

      1. bravewarrior profile image93
        bravewarriorposted 2 years ago in reply to this

        P.S. thanx for the broken link link. I wasn't aware of it.

  3. LindaSmith1 profile image60
    LindaSmith1posted 2 years ago

    I forgot how it works here.  But if a Amazon product is no longer available or ASIN has changed, it affects the link as well, because there will be a new link for ASIN  and when some merchants don't have product listed at all anymore,, the link will be broken as well.

    1. bravewarrior profile image93
      bravewarriorposted 2 years ago in reply to this

      I'll test that as well, Linda. Thanx. If only we could be paid for the time it takes to "fix" our hubs! :-(

  4. flycatcherrr profile image87
    flycatcherrrposted 2 years ago

    If you can give us the title of your hub, Shauna, I'd be happy to take a look and try to help track it down.  Just waiting on a phone call here, so have a bit of time on my hands...

    1. bravewarrior profile image93
      bravewarriorposted 2 years ago in reply to this

      Thanx, flycatcherrr. It's The Gifts of Faith - The Rainbow (Ch. II) Here's the link: http://bravewarrior.hubpages.com/hub/Th … nbow-Ch-II

      Any help you can give me will be much appreciated. I always fix errors when they're shown in my account. I've not been able to make this one go away and I'm befuddled over it.

      1. flycatcherrr profile image87
        flycatcherrrposted 2 years ago in reply to this

        I'm on it... will get back to you shortly.

        ... OK, try putting www in front of the URL link to fotor.com and see if that helps?
        It's technically not a broken link (200 not 404 error) but I'm just not seeing anything else (yet).

        1. bravewarrior profile image93
          bravewarriorposted 2 years ago in reply to this

          Flycatcherrr, Matthew responded and told me what to check. I've fixed the link and the warning's gone. Thanx for wanting to help!

          1. flycatcherrr profile image87
            flycatcherrrposted 2 years ago in reply to this

            Glad you got help from the official source - sorry I was slow off the mark. wink

  5. LindaSmith1 profile image60
    LindaSmith1posted 2 years ago

    Since I moved my hubs to my own sites, and another platform, I don't have anymore bugs, quirks, etc.  Once in awhile an Amazon product is changed or pulled.

    1. bravewarrior profile image93
      bravewarriorposted 2 years ago in reply to this

      Linda, I would venture to say that none of our own sites, mine included, receive the ranking and/or traffic that HubPages gives us. The changes may be a pain in the ass - and they are - but it's the nature of the Internet. If you want to succeed, you have to play by the rules. It's as simple as that. HP is trying to give each of us the biggest advantage they can. In order to do so, they have to comply with Google rules.

      Go ahead and Google yourself. What comes up first (outside of G+ and Twitter)?

      1. Faith Reaper profile image87
        Faith Reaperposted 2 years ago in reply to this

        I know that when I Google Faith Reaper, I am at the top but Twitter and the rest follow down. I don't have a site of my own so nothing to compare it to ... as far as the broken links go, I am glad you figured it out. Here lately when they say I have a broken link, it never shows up on the hub under edit mode, but if I go under my account under broken links it is there highlighted in pink.

  6. LindaSmith1 profile image60
    LindaSmith1posted 2 years ago

    bravewarrior:  My views have gone from maybe 200 a month for over 70 hubs, to a lot less than that on each site,  which avgs 200 views a day.  Both of my new sites just using keywords for site themselves, are first page of Google search. My sales are up.  No bugs.  I control my site. I don't have to play the guessing game.

 
working