jump to last post 1-7 of 7 discussions (9 posts)

My HubStats haven't updated in almost 3 days now...

  1. AndrewHil93 profile image38
    AndrewHil93posted 17 months ago

    It just has the message: Includes data from 2 days ago and earlier.

    Am I the only one? Is the site going through major updates or what? I've not received any emails... And I'll confess, I've not been keeping up with the Hubpages blog...

    Anybody else having the same issue or able to shed some light on the situation?

    Cheers. smile

    1. Barbara Kay profile image86
      Barbara Kayposted 17 months ago in reply to this

      The same thing is happening with mine.

  2. FatFreddysCat profile image93
    FatFreddysCatposted 17 months ago

    The hamster in the wheel that powers the stats counter must be on vacation this week.

    1. Chriswillman90 profile image89
      Chriswillman90posted 17 months ago in reply to this

      That hamster died of malnutrition a long time ago.

  3. relache profile image88
    relacheposted 17 months ago

    Many of us don't bother much with the site stats due to these frequent issues and just look at Google Analytics.

  4. Jan Saints profile image77
    Jan Saintsposted 17 months ago

    Someone here said the stats update is delayed when the payday is near.
    I can now confirm. smile

  5. janderson99 profile image85
    janderson99posted 17 months ago

    I think broken stats is on a world record record attempt.
    Seriously, I thinks it is time to pass round the hat to get the funds to fix this problem, which has been ongoing for months and months. Stats data are important for me. I would be willing to contribute ($5 or so). Others?

  6. Sherry Hewins profile image95
    Sherry Hewinsposted 17 months ago

    This is a common occurrence. Honestly, I prefer it to what has been happening lately, where it falsely says you have a quarter your usual number of views.

  7. AndrewHil93 profile image38
    AndrewHil93posted 17 months ago

    It has updated now. big_smile