jump to last post 1-2 of 2 discussions (6 posts)

Fixing problems with Facebook shared URLs

  1. Becca Linn profile image92
    Becca Linnposted 16 months ago

    I'm having issues with the link for my most recent hub.

    If I copy and paste the link into a search bar, it does indeed to go my hub, but when I pasted it onto Facebook to share with my friends, the image and hub description that came up were not for my hub.

    Interestingly enough, if you click on the link, the picture, or the description on Facebook it still takes you to my hub, but I want my own hub's image and description to show on Facebook rather than this other random one.

    I've never had an issue like this before, and I'm wondering if anyone knows how to fix this issue.

    1. Matthew Meyer profile image78
      Matthew Meyerposted 16 months ago in reply to this

      It sounds like you may be trying to share a Hub before it has passed the QAP and is featured.
      There is info in the FAQ here.
      http://hubpages.com/faq/#social-media-promotion

      1. Becca Linn profile image92
        Becca Linnposted 16 months ago in reply to this

        Thanks! I think that's exactly what happened.

        1. Matthew Meyer profile image78
          Matthew Meyerposted 16 months ago in reply to this

          The FAQ I linked above has this information as well, but if this occurs, you can force a recheck of the URL here.
          "Fetch new scrape information"
          https://developers.facebook.com/tools/debug/og/object/

  2. Becca Linn profile image92
    Becca Linnposted 16 months ago

    Thanks so much! That's extremely helpful!

    1. Becca Linn profile image92
      Becca Linnposted 16 months ago in reply to this

      Problem solved! Thanks again!!!

 
working