jump to last post 1-6 of 6 discussions (7 posts)

Sharing SoapBoxie `Hubs' to Facebook is not producing a thumbnail

  1. Thomas Swan profile image93
    Thomas Swanposted 4 months ago

    My latest hub was moved to Soapboxie. I'm OK with that, but it seems sharing from this new site produces problems for Facebook. Normally I would get the top picture from the article displayed with a link when I share it on facebook. I'm only getting the link with no picture. Why? I tried refreshing the page (because sometimes that works) but it just won't display the picture.

    It worked fine on Google+. My link and picture were both displayed when sharing there. Just not on Facebook. I'd rather not be on Soapboxie if sharing an article is going to be this much more difficult. A picture can be good for attracting views...

    1. eugbug profile image94
      eugbugposted 4 months ago in reply to this

      I've noticed this frequently happens on Facebook. If the post is deleted and the link re-added, it seems to work the second time. Perhaps there's some sort of timeout which causes the post to appear without the thumbnail if the image isn't acquired in time from the target URL.

      Edit - Have a look at this thread: http://hubpages.com/community/forum/977 … n-facebook

  2. Stacie L profile image89
    Stacie Lposted 4 months ago

    I just tried it on my SoapBoxie hub and it worked. maybe emptying cache or history?

  3. lisavollrath profile image88
    lisavollrathposted 4 months ago

    Go to https://developers.facebook.com/tools/debug/

    Paste your link there, press debug, and then try sharing it on Facebook. It should work, and show your thumbnail.

  4. agilitymach profile image99
    agilitymachposted 4 months ago

    I have had the same issue, and doing the above has worked for me as well.  It's important as I choose top quality photos at the top of my Hubs so that they stand out in FB newsfeeds. smile

  5. Thomas Swan profile image93
    Thomas Swanposted 4 months ago

    Thank you for your comments everyone. Your solution (Lisa) worked. After debug threw up some weird warnings, I hit "scrape" a couple of times and it fixed itself.

  6. misterhollywood profile image94
    misterhollywoodposted 4 months ago

    Try a URL shorter. It almost always works.