jump to last post 1-3 of 3 discussions (7 posts)

Google and Microsoft Products Have Become Extremely Slow

  1. eugbug profile image95
    eugbugposted 4 weeks ago

    Has anyone noticed how these products have become very unresponsive in the last few months? Adsense and Google Analytics take ages to load as does OneDrive. I keep getting a 'loading' notification in Google Analytics. I have a 100 Mbs connection and no images have to be loaded when accessing Adsense or Analytics, so it's not an issue with my computer being slow to deal with the pages. I can navigate quickly around HubPages. I suspect it has something to do with security.

    1. TIMETRAVELER2 profile image92
      TIMETRAVELER2posted 4 weeks ago in reply to this

      I have no problems with Adsense, but Analytics does seem a lot slower than it used to be.

      1. eugbug profile image95
        eugbugposted 4 weeks ago in reply to this

        Sometimes it can take up to a minute for the Real Time option to display. It also now says "loading" all the time. Maybe it's just that there are so many people using the product.

  2. blueheron profile image96
    blueheronposted 4 weeks ago

    It could be other things--though I only know of one offhand. My computer slowed to a crawl recently, to the point that it wouldn't load some sites at all. What happened was, I was being overwhelmed by ads. (I was getting a lot of "unresponsive script" warnings.) This was probably because I made a lot of online purchases for soap making supplies for my soap business. The problem went away when I installed Adblock, which is a good thing to have in any case.

    1. eugbug profile image95
      eugbugposted 4 weeks ago in reply to this

      I occasionally get unresponsive script warnings but that's either because there's a bug in the script or maybe a browser doesn't support newer versions of script.

  3. Will Apse profile image90
    Will Apseposted 4 weeks ago

    I imagine they have intermittent technical issues but I haven't had any significant issues recently. Sometimes clearing your browser cache helps with this kind of thing. Or using a different browser. I use Firefox set to cache nothing which helps to quickly check if browser issues are a problem.

    1. eugbug profile image95
      eugbugposted 4 weeks ago in reply to this

      I do clear the browser cache, but it doesn't seem to make any difference. The delay most seems to be when loading GA Real Time after switching fro another option in GA. It can take up to 50 seconds to load.

 
working