Formatting suggestions

  1. 0
    daflaposted 8 years ago

    I recently tried to copy and paste something into a different text module that had links.  The links did not make it through the paste.  I would like to suggest that we have some sort of formatting where we could use "paste with html" or "retain formatting" so that this will not happen.  At this time, all I can see to do is paste all the links in a separate links module, which would be a bit too much work right now.

    I was able to save the links, because I just copied, didn't delete, the original content, so it's o.k., but it still is a problem.

    Also, I'm having a real problem with pre-formatted text not keeping its formatting past the save.  It looks fine in the paste box, and fine once I insert it, but once I save, the "preformatted" designation goes away, and I'm left with paragraph spacing.  I was trying to paste something that had single and double spacing (song lyrics) into the middle of a hub.  I thought that might be the problem, but even when I tried to put it into it's own text box, it didn't work.  I'm thinking this would be a problem for people trying to paste quotations or poetry as well.

    Is this just a glitch, or is there a solution to this problem?  So far, everything I've tried has failed.

    1. Lissie profile image86
      Lissieposted 8 years ago in reply to this

      Paste in function strips everything out except the carriage returns (maybe) - I suspect this is deliberate so that it makes it harder for spammers but its annoying when it happens particularly from 1 text capsule to another!  Sorry I havent used the preformatted option - maybe its new so you might have found a bug

  2. Jerrico Usher profile image61
    Jerrico Usherposted 8 years ago

    Have you tried to open the html in a web editor for example (or microsoft word) then copying it in the published tab (how it will look on the page) with links in there then pasting that, or if you did that try pasting it in the raw html format.. if the raw format doesnt work I think the published format (usually the copy retains the codes for it in the background and the text box automatically decodes it.. the html may be confusing it with tags that are unsupported and in the cleansing code of this site it may be stripping off all the tags.. hope this helps