jump to last post 1-25 of 25 discussions (30 posts)

Affiliate settings - Amazon

  1. guzie profile image61
    guzieposted 9 years ago

    Anyone know why I can't update the settings on the amazon edit window.

    When I enter the AISN number or keyword search I get "No Amazon results found".
    Yes I do have my affiliates settings correct on the affiliate setup page.

    Thanks from
    Paul Guzman

  2. C.M. Vanderlinden profile image71
    C.M. Vanderlindenposted 9 years ago

    This is going to sound really dumb, but are you clicking the "Preview" button after you enter your ASINs? Just hitting the "Enter" button on your keyboard doesn't do anything. I learned this after trying to make several Amazon capsules where no products would show up.

    If that's not it, then I don't know. I just added an Amazon capsule to one of my hubs and it took the ASINs fine.

    Good luck!

  3. guzie profile image61
    guzieposted 9 years ago

    Yes...I am clicking the grey button that says "Preview Amazon Results"

    The little whirling icon goes on about 1 second then disappears.
    BTW - I joined hubpages yesterday...could be my account is not yet setup ?

    Thanks again
    From Paul

  4. guzie profile image61
    guzieposted 9 years ago

    Ahhh I found the problem....I have to make sure that on the display options tab the type of search is still set to keyword if you want a keyword search. Or set it to AISN if you want to enter the AISN numbers.

    Thanks for the help
    from
    Paul Guzman

  5. C.M. Vanderlinden profile image71
    C.M. Vanderlindenposted 9 years ago

    Glad you figured it out smile

  6. relache profile image87
    relacheposted 9 years ago

    I've found that in ASIN mode, items not offered directly for sale via Amazon often won't come up.  This makes many third-party items on that site unavailable. 

    I know it has something to do with how the HubPages Amazon capsule works, as I mentioned this to Paul when I visited the HubPages HQ.  I'm hoping it's one of those things on the ever-growing "to do" list, as it seems to be a big factor in why my Amazon sales on my Squidoo lenses out-pace my HubPages by a magnitude or two.

  7. C.M. Vanderlinden profile image71
    C.M. Vanderlindenposted 9 years ago

    Thanks, relache! I had wondered about that. I get a lot more sales from my site. Almost all of the Amazon money I earn seems to come from items purchased from third-party sellers.

  8. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    As of today, you should be able to use items from 3rd party merchants with the amazon capsule.  It was actually a pretty easy change that slipped below my radar (thanks for the reminder Relache).   Please let me know if its working better for you.  There will probably be some change in the products listed for existing keyword search capsules as a result.

    1. pauldeeds profile image
      60
      pauldeedsposted 9 years ago in reply to this

      Did anyone notice this change?  I wouldn't mind some feedback on whether it works and if it is an improvement.  Thanks.

      1. relache profile image87
        relacheposted 9 years ago in reply to this

        My experiments with getting more fairy wings on my hub failed both for keyword searches or ASIN.  :-(

  9. Lissie profile image87
    Lissieposted 9 years ago

    For the last 24 hr or so I am not getting any listings from Amazon at all!

  10. AuraGem profile image78
    AuraGemposted 9 years ago

    I am glad of this thread! In the last 24 hours, suddenly all my Amazon connections in each hub disappeared. I have tried to rectify it, but I keep being told "No results found", no matter what keyword I type. Yet it was all fine before!

    Any ideas????

    Smiles and Light

  11. AuraGem profile image78
    AuraGemposted 9 years ago

    lol oi Lissie! Our postings are so close!

    Wonderful if our Oz connections are tangling threads! lol

    Just a thought!

    Smiles and Light

  12. robie2 profile image90
    robie2posted 9 years ago

    Thanks for this thread-- I thought it was just me.  I just posted my first hub so I'm still getting used to all the bells and whistles.  I had an existing amazon affiliate account from a website I had years ago so when I logged onto Amazon the old account with my old tracker came up.  I put in a new hubpages tracker for that account and thought all was well.  But no--after several hours I am still getting "no results for Amazon".  I just went back and changed back to my old original tracker on both the amazon site and hubpages.  I'm still getting no Amazon ads. What to do??BTW I love hubpages and see that I could become a real hubaholic:)

  13. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    Ok, I made another little tweak to the way keyword searches work.  I think it will work a little better now but you still may need to play around with the keywords and the product area you select.

    The amazon affiliate account you use shouldn't have any effect on getting results in the capsules.  One thing that is a little confusing about the amazon capsule is that you need you need to select either "keyword" or "asin" under the display options tab so that it matches with the type of search you have entered data for.

  14. robie2 profile image90
    robie2posted 9 years ago

    Yipeeeee--it works now-thanks. I'm in keyword mode notASIN and I think the problem was I had too many keywords.  I just used two and presto.  Back to hubland:-)

  15. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    Yes, the amazon search will require all the words you enter to be in the product listing -- so fewer is generally better.

  16. AuraGem profile image78
    AuraGemposted 9 years ago

    OEEEEEEEEEE!!!

    My screen suddenly did a funny little "rain dance". I was typing a comment to a hub, but my screen jumped back to this forum thread! (I'm not daring to ask how!) But I checked one hub and all my Amazon connections re-appeared! Magic! I have just checked all my hubs and they seem fine!

    Thanks for the prompt assistance Paul! Great work!

    Smiles and light

  17. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    Glad to hear it's working again.

  18. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    Relache, give it another try.  It turns out it was a little more work than I had thought.  The only limitation now, is that for the "All" keyword search you can't get 3rd party items.  For ASIN, or area specific searches you should be able to now.

    1. relache profile image87
      relacheposted 9 years ago in reply to this

      Hmmm, it's kinda working now.

      Here're the ASINs I'm trying to pull
      B0012I8RIQ
      B000WRZX0I
      B000BLA17A
      B000NQK290
      B000QXICVA

      But the capsule told me the first three can't be found or displayed, and yet I'm seeing them as for sale and in stock on the Amazon site.  In fact, they are listed as being some of the bestselling items.  Any idea why they don't come up?

  19. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    We require that amazon provide us the small size image url and the price in order to display the item.  For some reason they are not providing that data via their API for those 3 items (even though they seem have them on amazon.com).

    I suppose we could display the items without the price (and even without the image), but it seems likely that conversion rates will be better with that data.  I'll try and investigate a little more next week.

  20. jaymz profile image79
    jaymzposted 9 years ago

    I just tried it on 2 shirts from amazon, and the ASIN numbers wouldn't show. It didn't even say that the ASIN numbers picked couldn't be found. It just said no results. I had the option for ASIN selected.

    I tried:
    B000VLY4PA
    B000RZL1S8
    B000VQZBRA 
    B001290Z12

    And, none of them work. :-\

  21. pauldeeds profile image
    60
    pauldeedsposted 9 years ago

    The problem with each of those is lack of pricing data.  That seems to be pretty common with 3rd party items, so I'm going to lift the requirement on price for now.

  22. relache profile image87
    relacheposted 9 years ago

    Thanks for the clarification, Paul.  That is an interesting thing to know.  Over on "that other site," we have an option where we can enter our own descriptions for items, and that's how I work with things that don't automatically pull the prices.  My many years of sales/retail intel shows that having a prices does a lot more to encourage a sale than not.  Even if the feed on HubPages allows items that don't show a price, I'll take the time to find items that come up with one.

    1. caspar profile image83
      casparposted 9 years ago in reply to this

      As a customer I'd agree.  I rarely bother to look for more information if I don't see a price straight away, at least for impulse buys.  That goes for real shops as well as online.  I think if they can't be bothered to tell me the price, I can't be bothered to ask and I won't bother to buy it.  If I was really searching for a specific item of course it would be different, but I guess we're mostly going after impulse buyers on hubs?

  23. relache profile image87
    relacheposted 9 years ago

    It's hard to say if it's more impulse buying or not.  However, when shopping over the internet, people can't touch an item and they have to rely a lot more on written descriptions, so the price becomes a more important factor.  Given that HubPages retail capsules only show a picture, a name and a price, that makes it really important.

  24. profile image0
    The Lonely Hubberposted 8 years ago

    Hello

    I am a new hubber but with an existing Amazon affiliate account.  Am I right when I say that all I need to do when I edit my Amazon affiliate settings is to enter my existing Affiliate Code and it will take care of itself? Or do I have to apply for a new account?

    Thanks!

  25. profile image0
    J Mockridgeposted 8 years ago

    Entering your current Affiliate code should work fine.

    1. profile image0
      The Lonely Hubberposted 8 years ago in reply to this

      Sigh! Thanks very much for the response. wink

 
working