jump to last post 1-16 of 16 discussions (21 posts)

Amazon Affiliates

  1. Whitney05 profile image63
    Whitney05posted 8 years ago

    Ok, so today I noticed that for the past several months, since I've been at HubPages, my amazon affiliates ID was wrong... I somehow managed a "!" at the end of my ID. But, I could have sworn that it was there when I copied it from Amazon Affiliates site to here. But, now I see the ID without the !

    So, anyway... Whenever I need my ID, I come to HubPages to grab it from the affiliates tab. So, I have just realized that just about everywhere I've used the ID, I've had the exclaimation mark after it. :-\ The only links that I have that have been correct were those I made for my blogs while in the program. So, that sucks...

    Could this be one of the reasons why I've had NO sales?

    Also, is there a reason why I see clicks in my Amazon Affiliates page, when I've been using the wrong ID, except for in two other places (to which I doubt had many clicks)?  The day or so after I started using the code on another site, I saw a ton more clicks, but again, the code had the ! at the end.

    I've spent the morning removing them all.

    1. relache profile image86
      relacheposted 8 years ago in reply to this

      If there's ever a time to really do a check of what you typed, it's when using an affiliate code.  Most likely this is the culprit.

    2. huba7 profile image60
      huba7posted 8 years ago in reply to this

      What is the Amozon Afilliates and how does it work-I was keen simply know more aboout it-can you elaborate please?

  2. Misha profile image75
    Mishaposted 8 years ago

    Whitney,

    Considering all details you outlined, I think you better ask their customer service.

  3. Whitney05 profile image63
    Whitney05posted 8 years ago

    I didn't think I had any concerns as I copied and pasted it... :-\

  4. 0
    daflaposted 8 years ago

    Now I want to go check mine, because I managed to get the wrong code for analytics, although I too, copied and pasted.  I've had no sales on Amazon either.

  5. Marisa Wright profile image94
    Marisa Wrightposted 8 years ago

    Whitney, when you click the "check your earnings" on HubPages, does it take you to the right place? 

    D'uh, just realised that doesn't tell you anything, since you have to enter your email and password to log in anyway.  I just opened Amazon and HubPages side by side so I could compare and make sure they were the same.

    I hadn't checked my earnings for ages, and got really excited when I saw there were 7 orders!

    But I haven't earned any money.  Guess whoever it was must have cancelled their order sad

  6. sunstreeks profile image81
    sunstreeksposted 8 years ago

    I did the same thing with my Ebay ID. I grabbed the account number at the top of my cj.com screen instead of my pid. I corrected it yesterday and out of 4 hits, 1 of them resulted in a sale. 

    Considering one of my high traffic hubs is meant to draw attention to a item that is best bought on ebay, I wonder how many sales I lost because of this.

    Oh well. lesson learned smile

    1. funride profile image69
      funrideposted 8 years ago in reply to this

      sad I just notice I´ve made the same mistake. Thanks to you all I´ve already correct this, thank you!

      1. Stacie Naczelnik profile image88
        Stacie Naczelnikposted 8 years ago in reply to this

        Same here.  Doh!  I sure feel silly.

  7. Whitney05 profile image63
    Whitney05posted 8 years ago

    Looks like me posting this mistake has helped a few of you. Ha.

    You guys had me worrid about my Ebay ID, so I immediately checked it. And, I have the number at the top of my account. I'm not sure where to find my Ebay ID.

  8. sunstreeks profile image81
    sunstreeksposted 8 years ago

    Hi Whitney,

    yes thanks, I'm glad I took the time to go check on my account #'s after seeing you were having problems.


    sign in to cj.com

    go to account tab

    then website settings

    On the left is your PID  smile



    I wonder how many hubbers don't have sales with ebay because they used the account number at the top of the page.

    I think our affiliate sales might start to improve wink

  9. sunstreeks profile image81
    sunstreeksposted 8 years ago

    You know,

    this is the kind of thread it would be nice to mark with a sticky. A must read for members so they don't make the same mistake.

    1. belief713 profile image80
      belief713posted 8 years ago in reply to this

      Ditto on the sticky thing - I think a lot of forum posts need sticky's. It'd save me a lot of time searching! smile

  10. Whitney05 profile image63
    Whitney05posted 8 years ago

    Thanks sunstreeks!
    I wonder how many sales I lost because of using the CJ ID versus the PID.

    When in HubPages you have to put your HubPages PID correct? As I have different sites set up. I'm curious as to if it matters which one? Of course, I'm using the HubPages PID, but out of curiousity.

  11. Whitney05 profile image63
    Whitney05posted 8 years ago

    Oh, and that "!" after my ID did affect my sales. Because after changing it just the other day, I've had 3 sales. :-( Pooh. Oh well. Lesson learned. Right?

    Just one question though:  What's the difference between Revenue and Referral Fees?

    Wait another questin: I show 3 sales, but only 2 have shipped. When the 3rd ships, with the revenue show?

  12. Whitney05 profile image63
    Whitney05posted 8 years ago

    anyone?

  13. Mark Knowles profile image62
    Mark Knowlesposted 8 years ago

    Yes. big_smile

  14. Jaelyn profile image59
    Jaelynposted 8 years ago

    YES INDEEDY! smile

  15. Inspirepub profile image86
    Inspirepubposted 8 years ago

    Anyone want to make a Hub with links to all the Forum threads that should be "sticky"?

    Jenny

  16. Mark Knowles profile image62
    Mark Knowlesposted 8 years ago
 
working