jump to last post 1-4 of 4 discussions (10 posts)

The quiz capsule had me in fits!

  1. wordscribe43 profile image92
    wordscribe43posted 5 years ago

    The quiz capsule has some behavioral problems.  It likes to play the funny little trick where it duplicates your questions, sometimes just doubles, but if it's particularly fussy, it will go for triples!  Grrrrr....  I had to give up with one capsule and totally abort. 

    The only way I've gotten it to work (and mind you, it's not fool-proof) is to just delete all the questions if I have doubles.  Then, if I'm lucky I might get the right number of questions. 

    Thought you should know.  BTW, I had this problem in Firefox and IE.

    One more thing... none of the options in the quiz capsule are very Likert Scale friendly.  It would help to have a results option that isn't measure in % or only chooses the highest points as your result.  In other words, one you can customize for points, i.e.  If you scored between 1 and 30 points, then you get this result, between 31 and 60, that result... and so on.

    1. larryfreeman profile image85
      larryfreemanposted 5 years ago in reply to this

      Hi Wordscribe43,

      Thanks very much for your feedback.  I am in the process now of investigating the quiz capsule issue.

      I will update this thread when a fix is found.


    2. J Sunhawk profile image81
      J Sunhawkposted 5 years ago in reply to this

      I tried the quiz capsule a few weeks ago and found it difficult to use. It seemed real buggy and hard to control. I threw it out and haven't tried it since.

  2. wordscribe43 profile image92
    wordscribe43posted 5 years ago

    Thanks so much, Larry.  I appreciate your fast reply!  I will be looking for the fix.

    1. larryfreeman profile image85
      larryfreemanposted 5 years ago in reply to this

      Hi Wordscribe43,

      I am having trouble reproducing the issue.  Are you seeing the problem every time?  Is there any steps that you are following that results in the problem?

      I am able to add a rule to the database which will prevent duplicate quiz entries.  That will stop duplicate quiz entries but it may also result in an error being generated under certain circumstances.  If I can reproduce the problem on my local machine, then I should be able to cleanly fix it.

      Thanks very much for any information that you can provide me to help me reproduce the issue.


      1. wordscribe43 profile image92
        wordscribe43posted 5 years ago in reply to this

        Strange you can't reproduce it.  I am not doing anything out of the ordinary when I get the duplicates, just add questions, answers and assign appropriate points to them.  I will get an error message almost every time I save the capsule, though.  I can't remember off-hand what the message says, as I'm sure that would be quite helpful for you.  Oh yeah, often the whole page goes gray, too.  Just flat out "out to lunch" after I save the quiz.  So, I have to reload to get back into my hub and edit mode.

        Much to my chagrin, yes... I get them every time I try to make a quiz.  I will try to make another quiz, take note of the error message and let you know, if that helps.

        Thanks again, Larry.  Aren't you working a bit late?

  3. wordscribe43 profile image92
    wordscribe43posted 5 years ago

    Here's the message I get:

    "There was an error saving this capsule.  Please click EDIT and then SAVE to try again.  This error will be reported to the HubPages engineering team.  We thank you for your patience and understanding."  I get that message nearly every time I save a quiz capsule.

    I didn't have the duplicate problem this go round, Larry.  Perhaps your rule did the trick. 

    Any way you could consider a Likert-Scale specific quiz capsule, though?  I had to choose one that shows the % to make my results work.  But, the answers have nothing to do with percentage, rather point totals which place them in different categories.  None of the capsules works for this type of quiz. 

    My most recent hub has a quiz that demonstrates what I'm talking about, if that helps.

    1. kimberlyback profile image61
      kimberlybackposted 5 years ago in reply to this

      I am having this same problem and I cannot seem to find any solution or help. I cannot save any edits to my quiz. I have lost the quiz 3 times now. In its current state it is unpublishable, yet when I make edits I receive the same error message and cannot save any changes. I am losing my mind over this. lol. No, seriously.

    2. cascoly profile image59
      cascolyposted 5 years ago in reply to this

      no one's asnswered, so i'll reply to a possibly stale question

      i notice this error sometimes too - it usually happens for me when i use the link capsule.  i think it may have something to do with the speed of the connection, since many times when i get the error message the acxtual changes HAVE been saved.  my solution otherwise is to exit the hub and try again, but after first copying any new text i may have added. [obviously that may not work in all cases]

  4. cascoly profile image59
    cascolyposted 5 years ago

    Quizzes with pictures are a big improvement over text only ones.  I've used the quiz capsule in several of my hubs, but a BIG disadvantage is that if you connect pictures with your quiz,  the widget   doesn't copy the pictures when it's posted somewhere else.  There's no way to disable the ability to grab a widget, either.