Problems w Adding Amazon Products

  1. melbel profile image93
    melbelposted 5 years ago

    I'm not sure if this is a problem on HubPages end or with the Amazon API, but many items on my hubs has disappears. Upon editing, HubPages says the products do not exist on Amazon. I search for them on Amazon, and they are there with the same exact ASIN that I have listed.

    When I first noticed the problem, I went to Amazon to find other products to add to the hub to replace the missing ones and the ASINs right off Amazon showed as "non-existent" to HubPages. About 80% of the products I try to add are showing up as non-existent in my hubs.

    I normally wouldn't complain, but it kind of messes up the format of my hub when products "go missing."

    I understand that there are times when products are no longer for sale on Amazon, but tonight I'm getting this "there aren't any amazon products with this product number or whatever" is showing up, when they are there on Amazon's end.

  2. twilanelson profile image60
    twilanelsonposted 5 years ago

    I had something similar happen, a couple of the affiliate products disappeared. While I was having the problem I went to the affiliate site and could not find images for the items I had listed or items to replace the ones lost.  I believe the affiliate site was having an issue because the next day everything was back to normal.  It's kind of nice to know someone else is also working on the same issues I am having.  Have a wonderful day.

    1. rafibarlev profile image60
      rafibarlevposted 5 years ago in reply to this

      Wow, hope you're able to get it worked out. I have no idea what the problem with Amazon is.