1. 0
    Check021posted 5 years ago

    I have connected my Hub profile with Ad Sense after my second hub.I had no difficulties to do that,BUT:
    For a week, I can't get no data about my earnings or whatsoever??
    I have added a custom channel like ,and just in case if something is wrong.When I get in to my profile, AdSense says it's ACTIVE. And advertisement on my hubs are there, not on every,but on most of them - there are ads. check them out on . There are ads.
    BUT, still - I have impressions I have page visits I have everything I need to show at least SOME DATA - but ,there is no any data. Why is that happening???
    PLEASE, this is question for H.P staff too - because I am not the only one that is posting good Hubs,getting advertisement of Google,Google earns from clicks - and giving us -NOTHING, no even a DATA about ANYTHING. What is going on, please help me.

    1. 0
      Check021posted 5 years ago in reply to this

      I forgot to say that Google Analytic is connected and working fine showing me traffic fine. And there is traffic and my friend clicked on some of ads ,and there are impressions but Ad Sense like not hearing for that.My friend even bought something from the ad that was displayed on my hub.

      1. sofs profile image87
        sofsposted 5 years ago in reply to this

        Adsense pays you for clicks..not for impressions.. and it takes a lot of traffic to get clicks.. don't worry the clicks will start coming... you will be seeing some adsense earnings in time smile