keyenhancer profile image 73

People are reading my hubs, but Hubpages stats are not showing it.


I use a few different tools that show people are going to my hubs, reading it and such but Hubpages' stats are updating to reveal it. I am using bit.ly links, but I always have without any issue. Any ideas on what could be causing this?

 

sort by best latest

FatFreddysCat profile image95

Keith Abt (FatFreddysCat) says

You can help the HubPages community highlight top quality content by ranking this answer up or down.

2 years ago
 |  Comment
  • keyenhancer profile image

    J. L. Tracey (keyenhancer) 2 years ago

    Thank you for the response, that makes sense considering. At least my score isn't suffering as a result. :)

Edwin Thomas profile image84

Edwin Thomas says

You can help the HubPages community highlight top quality content by ranking this answer up or down.

2 years ago
 |  Comment
  • keyenhancer profile image

    J. L. Tracey (keyenhancer) 2 years ago

    I know there is a delay, but it has been a couple days now. I do use google analytics, which is why I brought up the question. But thanks for the reply.


  • See all 2 comments
liladybugz26 profile image88

Rachael M Ryhn (liladybugz26) says

You can help the HubPages community highlight top quality content by ranking this answer up or down.

2 years ago
 |  Comment
  • keyenhancer profile image

    J. L. Tracey (keyenhancer) 2 years ago

    Thank you for the post. Now I have a hub out-ranking a higher score hub, so I'm not sure how that's working other than scores aren't updating now.