ArtsAutosBooksBusinessEducationEntertainmentFamilyFashionFoodGamesGenderHealthHolidaysHomeHubPagesPersonal FinancePetsPoliticsReligionSportsTechnologyTravel

HDA audio bus driver is required and not found SOLVED

Updated on August 13, 2013

HDA Audio bus driver is required and not found

HDA Audio bus driver is required and not found.

 
  • Step 1

Go to Start > Run and type Regedit

  • Step 2

This will open up Windows Registry Editor. Next, follow the location of the key below by navigation through the little [+] signs you see next to the folders.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\CDSVersion

  • Step 3

Change the value of the CSDVersion Dword and give it the value 200.

  • Step 4

Try to install your driver again, you should not get the error this time. Once installed, restart your computer and resotre the registry key back to 300.

Note: The 300 refers to the service pack you are running. In this example we fooled windows into thinking we had service pack 2, although we are actually running service pack 3!

Once you have restarted your machine you should have a fully working sound driver.

Thank you.

This article alone generates me $1.5 or £1 per day, every day on Hubpages. You too can make money from HubPages, click here to join (It's Free).

Did this work for you?

See results

Comments

    0 of 8192 characters used
    Post Comment

    • profile image

      AM 7 years ago

      Cheers for this Richard, this has been the only thing that's worked for me! Keep up the good work!

    • profile image

      Alan 7 years ago

      Hi there

      I have the same error but I am only running service pack 2 and the value under CSDVersion Dword is already 200.

      Any other suggestions that may help?

      regards

    • profile image

      nabin 7 years ago

      after running start>run>ok..............they show the message"registry editing has been disabled by your administrator"

    • richardmacarthy profile image
      Author

      richardmacarthy 7 years ago from United Kingdom

      nabin - your admin rights have been revoked for your user account on windows. Trying logging into another user account that has admin rights..or login to the administrator account on the computer.

      Hope this helps..

    • profile image

      nabin 7 years ago

      now it runs.........still when installing they show the same message

    • profile image

      nabin 7 years ago

      pls help me.....

    • richardmacarthy profile image
      Author

      richardmacarthy 7 years ago from United Kingdom

      Are on a domain? Or on a home machine? Try logging in as administrator. The account will have full rights for installing such programs. Make sure you have FULL admin rights.

    • profile image

      nabin 7 years ago

      home machine....XP Professional.i am the computer administrator...still....just tell me how to log in as administrator...."hda is requi..............and not found"the same message is shown....

    • profile image

      nabin 7 years ago

      pls give me your yahoo id so that i can add u as my friend...it would be easier for me...

    • richardmacarthy profile image
      Author

      richardmacarthy 7 years ago from United Kingdom

      The fix that I have detailed here may not be the fix for you. If you are still getting the error message I would advise to look for a different resolution. Sorry I could not be more help.

    • profile image

      Ridzy 7 years ago

      Hi,

      I have the same problem as that of Alan. I'm running service pack 2 and the Dword value is already 200. Please provide some sort of help as soon as possible.

    • richardmacarthy profile image
      Author

      richardmacarthy 7 years ago from United Kingdom

      This fix only applies to certain computers. If this fix did not work for you, you will need to check another article. Good luck with your search! And sorry I cannot be more help.

    • profile image

      Asmatullah Kohistani 7 years ago

      Hello,

      it didn't worked for me I am using XP Service Pack 3 installed on system HP Notebook NC6400 the file HP Provided me didn't work too once long ago I found a software on the net which workded me for me unfortunately I lost it as my USB Stick was virus infected any idea pleas.

    • profile image

      hassan ali jees 7 years ago

      the hda audio bus driver is required and not found

    • profile image

      Mohamed Syed 7 years ago

      I have followed your six steps, but still got dat prob as HDA Audio bus driver is required...

      Please Help me sir..

    • profile image

      Mohamed Syed 7 years ago

      I got it sir.. Thank you so much..

    • profile image

      Ressy 7 years ago

      Very good! Thank you!

    • profile image

      FCLTech 7 years ago

      This error can be caused by a bios option. If your bios has the audio option set to off or disabled, you will see this error. Turn on any audio options you see in your bios and then try again.

    • profile image

      Israel  7 years ago

      the hda audio bus driver is still and not found

      after cearfully followed the steps that you outlined.

      Pls what other step would you advise i try.

      Cheers.

    • profile image

      faculty 7 years ago

      hi rich,wat if you are trying to run windows 7?

    • profile image

      hassan ali jees  7 years ago

      how resolve that error

      "tha hda audio bus driver is required and not found"

    • profile image

      LOS 7 years ago

      Thank you for your wisdom- it only took me half a day to find this thread..It worked for me perfectly. I followed the steps exactly and i am listening to audio right now as I type this. Thank you again

    • profile image

      Chris 7 years ago

      This worked well for me. I was having all sorts of problems and I expected it to be straight forward as it usually is. I was stumped and this worked first try. Easy fix.

    • profile image

      Ravi kumar khatri 6 years ago

      I applied you processior through regedit to solve the problem of hda audio bus driver missing but the problem still remain. Please send me the link of hda audio bus driver downloading or send me other processior to solve the processor.

    • profile image

      ravi Kumar khatri 6 years ago

      Hi Richard. some futher imformation about my pc are:

      It has an IBM pc with Thinkcentre motherbord and I load windows Xp Service pack Two as operating System.But I select the downword value of cdsversion is 100 for this case But the problem is still remain( the same error massage when loading soundmax audio drivers.

      please help me. Your sincerely.

    • profile image

      Brooklyn 6 years ago

      This is the messed up part. PPl complainted about thei weren't gettin soundMAX to work. But its the same ppl who cant share how thei solved the hda driver prblm, instead of sayn "i got it" or wateva. I find that ril messed up, bcuz alot of us still havnt solved dis.

      Cheers,

      Brooklyn!

    • profile image

      Jaymz 6 years ago

      i have done the above, but still it comes up with hda not found? any other suggestions?

    • profile image

      Owais Ali 6 years ago

      Hi brother,

      I have the same error but I am only running service pack 2 and the value under CSDVersion Dword is already 200 which is also problem for Alan, who has asked this before. So, I request you that plz send me the solution on my id owais.buddy786@gmail.com

      Thanks.

    • profile image

      ALI 6 years ago

      DON'T WORRY GUYS I HAVE SAME PROBLEM BUT I HAVE ALSO SULOTION CHANGE YOUR WINDOW TO WINDOW 7 AND THEN INSTALL UR SOUNDMAX DRIVER IAM VERY SURE ITS WORK

    • profile image

      Iqbal Husian 6 years ago

      hey mine is window 7 and change the value also from 300 to 200 but still the error coming..any other solution

    • profile image

      aj 6 years ago

      me too.. after install windows 7 (from xp) that error appear. helllllpppp!

    • profile image

      enevic 6 years ago

      perfect guide ....thanks

    • profile image

      Nobdy 6 years ago

      (English) Windows XP Service Pack 2 UAA High Definition Audio class driver (Q888111)KB888111

      Install this first, then the driver.

    • profile image

      Kal 6 years ago

      hi,

      I've the same problem. I got IBM Z60m, XP SP3, all the time i didn't have any problem with my audio driver, then I lost the sound while I was playing NFS. Scinse, then I couldn't get it back.I've tried everything, reinstalling OS, various drivers and nothing works, and the weird thing that every time I get that the driver is ok, when i check my system properties i can see the driver (SoundMax Integrated Digital HD Audio)with no problems, speakers on the taskbar and mediaplayer works fine but no sound. Any advice, Help please

    • profile image

      Nick 6 years ago

      This doesn't work at all for me. I change the value to 200 then try and install my driver and still get the same error.

    • profile image

      Prabhu 6 years ago

      I can't uninstall 3D MAX Audio driver software from control panel.It is giving error"The HDA audio bus driver is required and not found".

      Even i changed Registry Key [KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows\CDSVersion]Dword nto 200.Till i'm getting the same error message

      Please give me the solution for this..

    • profile image

      Omgee 6 years ago

      Hey, Just wanted to SAY THANK YOU !

    • profile image

      greg 6 years ago

      Also doesn't work for me.

    • richardmacarthy profile image
      Author

      richardmacarthy 6 years ago from United Kingdom

      Hi guys, this method will not work for everyone so apologies if it didn't work for you. If it does not work for you, then you will need to continue your search. Make sure to return any values you changed in registry.

      Thanks.

    • profile image

      Endalew 6 years ago

      i can not able to solve the problem

    • profile image

      Action Burns 6 years ago

      Hi Richard. I must have service pack two as the value is already 200. Do you have any other suggestions? Thanks ahead of time.

    • profile image

      ian 6 years ago

      worked for me thanks

    • profile image

      alex 6 years ago

      if the problem is not solved write on www.google.com this:download KB888111.download instal then instal the audio driver.it work"s for me

    • profile image

      Jace Martin 6 years ago

      tried this procedure but it didn't work for me, now there's a new error message saying that the computer can't find the HD audio device...can you hep me? please...

    • profile image

      sid 6 years ago

      i have sv pack 2

      any help??

    • profile image

      Felix ( From Nigeria ) 6 years ago

      For those still having issues after trying out richardmacarthy's method, check out this link http://aolanswers.com/questions/HDA_audio_bus_driv... I tried it, and it worked for me. I hope it works for you guys. Take care.

    • profile image

      kish 6 years ago

      thankq so much

    • profile image

      FIZZY 6 years ago

      I must have service pack two as the value is already 200. Do you have any other suggestions?

    • profile image

      Felix ( From Nigeria ) 6 years ago

      Hi fizzy, check this link: http://aolanswers.com/questions/HDA_audio_bus_driv... I have posted it before.I hope this your situation

    • profile image

      milliondollarguy 6 years ago

      Downloading KB888111.exe worked for me guys, it must be a solution for u too.. Install this first, then try installing your driver.. All the best!

    • profile image

      jarrett 6 years ago

      i tried it but it didn't work it still told me the error thing

    • profile image

      samir deb 6 years ago

      thank you for your assistance.

    • profile image

      saadownz 6 years ago

      hay gays i tired trying solve it but finally i found the answer in bios

      the system has dafult disabled audio so you enter to bios and turn on the integrated audio and it's work

      thanks

    • profile image

      Mr Dyps 6 years ago

      you guys are cool. what Alex suggested worked for me. thanks guys

    • profile image

      Mr Dyps 6 years ago

      you guys are cool. what Alex suggested worked for me. thanks guys

    • profile image

      vijay gund 6 years ago

      Hi,

      I have the same error but I am only running service pack 2 and the value under CSDVersion Dword is already 200.

      Any other suggestions that may help?

      regards

    • profile image

      Abdul Jabaar juma  6 years ago

      hi guys i am experiencing the same problem and it drives me crazy because i failed to meet up the music video editing deadline, i did uploaded windows 7 on my my PC, i am stuck please help... i tried this system still doesn't work....

    • profile image

      Chris 6 years ago

      Very good advice. Thank you and very much appreciated!!

    • profile image

      Tanveer 6 years ago

      dear,i change the csdversion value,but there is no change ,sound driver is not installed ,plz give me another solution.my mailing address is

      h.m.tanveer@gmail.com,

      thankx

    • profile image

      firdee 6 years ago

      "FCLTech 15 months ago

      This error can be caused by a bios option. If your bios has the audio option set to off or disabled, you will see this error. Turn on any audio options you see in your bios and then try again."

      hey guyz...try this...it's WORK!!!...i'm using soundMAX audio...u juz need to enable ur sound controller option in ur bios setting...after that ur sound is back...good luck ^^

    • profile image

      jasonvincent 6 years ago

      I finally found a solution that worked for me!

      Win XP Pro SP3.

      A Microsoft hotfix that provides the HD audio drivers

      http://support.microsoft.com/kb/835221

      Hope that helps!

    • profile image

      a noob ppl 6 years ago

      have followed your six steps, but still got dat prob as HDA Audio bus driver is required...

      Please Help me sir..

    • profile image

      rajesh 6 years ago

      Hi all,

      i am having an hp6730s laptop,i am unable to install audio drivers even with proper cd,after following this scenario changing the dword value to 200 i able to install audio driver

    • richardmacarthy profile image
      Author

      richardmacarthy 6 years ago from United Kingdom

      Hey guys, I'm glad I could help some of you, sorry about the ones I couldn't help, I don't know any other fix.

      Rich.

    • profile image

      zohaib 5 years ago

      you need to download HDA bus driver , then instal the Audio drivers.

    • profile image

      sam 5 years ago

      in computer management look at the unknown device wth a ?. rght click it en go to update dreiver. choose option down to choose the driver from list. then select sound and video, find microsoft on list of manufatures and select the appropriate driver that appears on the right and install it. then install your soundmax driver

    • profile image

      Mahendra  5 years ago

      Ya sir this is really works on xp pac 1

      thanks too much ,

      gaikwad.mahendra@gmail.com

    • profile image

      Quickhitch 5 years ago

      HP should hire you. They just give general answers to do everything you have already done, then suggest you contact your network manager, which is yourself.

      IE "ask someone else"

      Thanks for the info and keep up the good work.

    • profile image

      samhabs 5 years ago from zambia

      which one worked for you tow guys, sam 's post

    • profile image

      waseem 5 years ago

      audio dr

    • profile image

      Robel 5 years ago

      iam going to die with out listing Justine biber musics helpppppppppppppppppppp

    • profile image

      IQBAL MORE COMPUTERS 5 years ago

      ALEX U ARE RIGHT..UR SOLUTION WORKED

    • profile image

      gavie 5 years ago

      gavie

      Hi there

      I have the same error but I am only running service pack 2 and the value under CSDVersion Dword is already 200.

      Any other suggestions that may help?

      regards

    • profile image

      gavie 5 years ago

      gavie

      Hi there

      I have the same error but I am only running service pack 2 and the value under CSDVersion Dword is already 200.

      Any other suggestions that may help?

      regards

    • profile image

      Anteneh 5 years ago

      i follow the step but still steel missing of HDA Audio bus driver available can i get another step

    • profile image

      usman 5 years ago

      i also follow the above steps but the value of the CSDVersion is already 200 in hexadecimal.So, still have a problem of HDA Audio bus driver plz tell me another solution...

    • profile image

      joseph abboud 5 years ago

      i have dell CHBLZ21 PC and the sound card is Analog Devices ADI 198x Integrated Audio how i can make the sound work i download the driver but i have HDA Audio bus driver are not found plz tell me another solution...

      i have xp service pack 3

    • profile image

      Ramarao Gadala 5 years ago

      Downloading KB888111.exe worked for me, it must be a solution for u too.. Download and Install this file from this URL

      http://download.cnet.com/kb888111-exe/3000-2110_4-... then try installing your driver.. and let me know once it works for you. All the best!!!

    • profile image

      Khaled 5 years ago

      Hello,

      it didn't worked for me I am using XP Service Pack 2 installed on Fujitsu Siemens Notebook it didn't work too once .

    • profile image

      crazy 5 years ago

      this is not working sombody help me how i kann this program instalation please help me

    • richardmacarthy profile image
      Author

      richardmacarthy 5 years ago from United Kingdom

      Hi Guys, apologies to those this didn't work for. If you find a solution please copy it back in a comment and I will update the page for others. Rich.

    • profile image

      mark 5 years ago

      i also follow the above steps but the value of the CSDVersion is already 200 in hexadecimal.So, still have a problem of HDA Audio bus driver plz tell me another solution...

    • profile image

      BrianJonesNC 5 years ago

      Search from the DELL home page for:

      R94481.exe

      This can also be found on the

      Dell Dimension ResourcCD P/N Y5993 Rev.A13 April 2005

      This restored sound on a Dell Dimension 2400

      with MB CN-0G1548-70821-42N-LOCA P/N 4117256100004.

      Took forever to figure this on out!

    • richardmacarthy profile image
      Author

      richardmacarthy 5 years ago from United Kingdom

      Thanks Brian! Very useful information.

    • profile image

      redzz 5 years ago

      yess thnx a lo!!! ur a great teacher!!!!!

    • profile image

      ALISHAH 5 years ago

      Plz can anybody help me ......!plz I'm done every thing with win xp 2008 SP-3 PROFESSIONAL EDITION.BUT there is 1 problem " i did every thing but i'm not finding "HDA bus Audio drivers" cn any 1 tell me what is that or where i get thiz plz............!

    • profile image

      subh 5 years ago

      I was try so many things e.g. installing many sound drivers.I read many articles and blogs but nothing worked out for me but your trick perfectly solved my problem....thank you.....

    • profile image

      Blaise 5 years ago

      Hey1

      here I have runing XP service pack 2

      but the Problem didn't resolved! so Tell me another way to pass! thank U

      regards

    • profile image

      nilesh 5 years ago

      here i m having windows 2003..i hav followed the same step but i m not having the option cds version in that..please help me out...

    • profile image

      cave 5 years ago

      HI

      I have changed the D 300 to 200 still the driver wont install. I still get the same error message.

    • profile image

      BdS 5 years ago

      After i changed 300 to 200 soundmax driver still didn't install on Asus motherboard. So i deleted the devices with problems(yellow triangle with exclamation mark) from device manager and restarted PC. Got into bios and changed the audio setting from HD to AC97 and restarted windows. System found problem PCI device again and i deleted it in device manager and restarted again. Went to bios and changed audio setting to HD again and restarted, when windows was starting it installed the correct drive for the missing device and i could install soundmax driver. I changed the reg setting back to 300 and sounds working fine now. windows xp sp3

    • profile image

      giddy 5 years ago

      just download kb888111 install it then restart ua comp then install ua sound max driver sp37155

    • profile image

      UmAr 5 years ago

      nOt wOrK At wIndOws 7 :-/

    • profile image

      Patrick 5 years ago

      Guys, you are going so far, its very simple this PCI device problem, in device manager panel look up for the PCI device then upgrade it using windows cd follow the prompts the missing file is found i368 folder install it after reboot the comp. then install sound drivers it work perfectly

    • profile image

      jimbarba 5 years ago

      Hi. I fixed my sound problem on my homebuilt WinXP SP3 machine! I have an ASUS M3A32-MVP Deluxe with Wi-Fi Motherboard. Its built in sound device uses SoundMax ADI Audio Driver. When sound stopped working, I tried a few things including installing the orig. CD and selected the SoundMax ADI Audio Driver section. I selected Reinstall or Upgrade option. I would get the following error "HDA Audio bus Driver is required and not found". I also got this same error when trying to uninstall SoundMax from Add/Remove programs.

      THE FIX that worked for me:

      Control Panel, System, Hardware Tab, Device Manager, Select in View menu 'Show Hidden Devices', Go to section 'Non-Plug and Play Drivers', Locate entry called 'Parport' which in my case had a yellow ! beside it, Right click Parport. (and here is where I cannot remember everything) I most likely selected Properties and somewhere found a button called 'Roll back to previous driver', Press that button.

      At this point the name changed. I would spell it out but once I rebooted and went back to the same spot, the name had changed back and no sign of the Roll Back button?? Also the ! was there?? I can say I think it had HD Audio in the name. I made no changes other than the Roll Back on first round and did nothing upon re-inspection even though it says it is not working!

      After the Roll Back and before any reboot, I installed the orig. MB CD and selected the SoundMax ADI Audio Driver selection on the menu. I selected Reinstall or Upgrade. It installed without error. I rebooted and the sound works!

      ASUS only has one Driver for SoundMax so the one downloadable from ASUS should be the same.

      Hope this helps!

    • profile image

      zbhex7 3 years ago

      i don't know what the story is but, if your having a problem with soundmax.then to fix it is very simple you have! to get (download manager)this file will download all the the files and drivers you need automatically from, setup.exe file you have on your laptop if you don't have it get it first. set.exe is the file that has ! all the files and drivers. where to get this fancy download manager is another story. I got it from Microsolf.of cause it would help if you have service pack 3. don't kill anybody just read and do

    • profile image

      jack 3 years ago

      You save my time. Thank's bro!

    • profile image

      Annapolos 2 years ago

      I changed the number still get hda error.

      Is it dec or hex 200?

      '

    • profile image

      Radu 2 years ago

      Hi all,

      After 2 days of searching I have the resolution for this.

      If you already try the steps from Richard then try to do it like that:

      Look in Device manager and if you don't see in Other device's your audio hardware then you should take a look in System Device and update driver for Microsoft UAA BUS Driver, you need only to follow windows steps and will be done.

      After this you will found your audio hardware in other device!

      And now you can try to install the device!

      Good luck and I hope will work for you too!

    • profile image

      JF 18 months ago

      Do the suggested down grade of service pack version in the registry to 100 instead of 200. Then install the kb mentioned above and then finally install your device drive.

    Click to Rate This Article