ArtsAutosBooksBusinessEducationEntertainmentFamilyFashionFoodGamesGenderHealthHolidaysHomeHubPagesPersonal FinancePetsPoliticsReligionSportsTechnologyTravel

What you need to know about Poodle vulnerability?

Updated on October 19, 2014

Poodle vulnerability

On October 14th, 2014, the Poodle vulnerability has been announced to the public.

The Poodle vulnerability is an attack on the SSL 3.0 protocol allows the plaintext of secure connections to be calculated using man-in-the-middle attacks.

Which mean, if you have connected to a public WIFI prepared by an attacker and used it to log in to your bank account or email account, or any other secure site (HTTPS), the attacker can steal your login info, and any other data transmitted in the site as encrypted data, like financial transactions or confidential emails.

The vulnerability is a protocol flaw which means that every implementation of SSL 3.0 suffers from it.

What I have to do as an IT administrator or as an end user?

If you are an end user using the internet at home or work, or if you are an IT administrator managing a web server, you have to do something.

End User

As an end user, all you have to do is to make sure that SSLv3 is no longer supported by your browser, and of course SSLv2.

How?

For Internet Explorer users:

You need to open the browser and go to Tools => Internet Options => Advanced

And remove the check from SSL 3.0 as in the picture.

Also you should remove SSL 2.0 if enabled; as it is already vulnerable.

You have to make sure that all TLS versions are enabled.

SSL 3.0 - Internet Explorer
SSL 3.0 - Internet Explorer

Chrome:

Start the browser with --ssl-version-min=tls1 argument as in the picture

SSL 3.0 - Chrome
SSL 3.0 - Chrome

Firefox:

We need to edit the internal configuration manually by typing in the address bar: about:config

Then in the search: security.tls

And change: security.tls.version.min from 0 to 1; to force the minimum version supported for SSL to TLS 1.0

SSL 3.0 - Firefox
SSL 3.0 - Firefox

IT Administrators:

All IT administrators should check all their systems (web servers, openssl, other secure systems) for support for SSLv3 and disable it.

A security update already has been issued for OpenSSL, so all servers should be updated to the latest OpenSSL version.

For Web servers running Apache, you have to disable SSL 3.0 in the server configuration and in each virtual host, using the below config, then restart Apache server.

SSLProtocol All -SSLv2 -SSLv3

For Web servers running NginX, you have to disable SSL 3.0 by changing the supported SSL version to the below config and then restart Nginx server.

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

For Web servers running IIS, you have to disable SSL 3.0 from the registry, go to the following key:

HKLM\System\CurrentControlSet\Control\SecurityProviders \SCHANNEL\Protocols

If not exist, create the following keys, SSL 3.0, and the following subkey Server

Then create a DWORD value named Enabled, with value 0, and then reboot the server.


SSL 3.0 - IIS
SSL 3.0 - IIS

Are you Vulnerable?

See results

Are you vulnerable?

You can check your public web server using Qualys SSL Test.

And your browser using Qualys SSl Client Test

© 2014 Mohammad Oweis

Comments

    0 of 8192 characters used
    Post Comment

    • mohammadoweis profile image
      Author

      Mohammad Oweis 2 years ago from Jordan

      Google and Mozilla confirmed that they will remove SSL 3.0 support in the next version of Google Chrome, and Mozilla Firefox.