jump to last post 1-6 of 6 discussions (10 posts)

What is i.betrad.com and why does it slow up the loading of a page?

  1. rebekahELLE profile image89
    rebekahELLEposted 4 years ago

    After editing one of my hubs, I noticed that it took forever to load and watched to see what it was waiting for, and i.betrad.com showed up.  I couldn't find too much about it while searching.  But one post associated it with malware.  I finally had to escape and try again, and the page loaded fine, and the site address didn't show up while loading.  Has anyone else had this issue or know anything about this server?

    1. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      @rebekahELLE I'm not sure about that specific domain, but it could have come from an ad that loaded.
      The malware warning could have been in error as well or just temporary.
      If you run into it again, let us know an example Hub and we can look into it.
      Many times it is hard to track down if it is indeed related to an ad as it is sometimes hard to get the same ad served.

      1. rebekahELLE profile image89
        rebekahELLEposted 4 years agoin reply to this

        Thanks Matthew. It probably was ad related.  I'll let you know if it shows up again.  I did not specifically get a malware warning, it just left the page hanging waiting for that site to load.

        I just clicked on the same hub and the address showed up again while I was watching the pages being read, transferred, etc.  But there is no malware warning

        1. bat115 profile image72
          bat115posted 4 years agoin reply to this

          it happened to me too.

  2. relache profile image88
    relacheposted 4 years ago

    If you look up that site on Google it explains what it is and what the site does.

    1. bat115 profile image72
      bat115posted 4 years agoin reply to this

      Relache, I missed you and your "let me google it for you" replies.

  3. rebekahELLE profile image89
    rebekahELLEposted 4 years ago

    relache, I did a google search and read most of the results.  My question pertains to why it is slowing up the loading of a page, as I found other search results with the same complaint with no real clear answers.  If an advertiser is using it, it's not to a sites benefit if it takes so long to load or leaves a page hanging.

    In case others may experience this problem, I did find this google advisory info.
    http://www.google.com/safebrowsing/diag … betrad.com

    The two host networks that it directs to have reported malware activity in the last 90 days, the most recent being today.  http://www.google.com/safebrowsing/diag … e=AS:14618

  4. brakel2 profile image84
    brakel2posted 4 years ago

    What browser do you use? We need to see if this happens to others. I will check mine. Thanks for posting.

  5. rebekahELLE profile image89
    rebekahELLEposted 4 years ago

    I'm using the latest Firefox on a Mac.   I checked it again, and I didn't see it or have the issue.  I also checked it on Safari and it was fine. It also loaded faster on Safari.

  6. brakel2 profile image84
    brakel2posted 4 years ago

    I don't see it with Firefox 11. I hope it's gone.

Closed to reply
 
working