this pc is on a lower vesion it required the 7.0 version...please bear with me..

  1. Mistress of Spice profile image39
    Mistress of Spiceposted 7 years ago

    this pc is on a lower vesion it required the 7.0 version...please bear with me..thkx

  2. krishubpages123 profile image31
    krishubpages123posted 7 years ago

    I will do bear for your pc and you can go on...

Closed to reply
 
working