jump to last post 1-3 of 3 discussions (9 posts)

My Google Analytics is not tracking anything from Hubpages

  1. SPomposello profile image79
    SPomposelloposted 5 years ago

    I entered everything correctly but I still can't track anything. It's telling me that I need to install tracking (i.e. copy/paste the tracking code on every page I want to track), but I don't think that's required if I'm not mistaken? All you have to do is add your analytics ID and that's it right?

    I've logged into Analytics, went into Edit Account/Data Sharing Settings, copy/pasted my account ID into where I'm supposed to put it on Hubpages affiliates. The problem is my analytics ID is 8 numbers long with no extra dash.

    So it's like this UA-12345678. That's it. When I enter it that way into Hubpages, it says it's not an appropriate value, that it's supposed to look like this UA-123456-7. I tried adding the extra dash before the last number and still nothing works.

    1. WryLilt profile image87
      WryLiltposted 5 years ago in reply to this

      Go into your analytics, go into edit (to the right of the Hubpages analytics set up) and double check the number.

      Then try re-entering it. Once you've done that press check - it can take up to 24 hours for Analytics to start showing data.

    2. khmohsin profile image59
      khmohsinposted 5 years ago in reply to this

      Yes your account id should be like this


      This is your analytics ID : UA-123456
      This is your website ID: UA-123456-7   ( 7 refer to site)

      did you add your page correctly ?

  2. cre8tive profile image81
    cre8tiveposted 5 years ago

    Have you added Hubpages to Analytics?

    The ID you are quoting is your base analytics ID. Each website you add to analytics is given a new ID which is the base one with a dash and a number at the end i.e.

    UA-123456 would be the base ID
    UA-123456-1 would be the ID for the first site you add to analytics
    UA123456-2 would be the ID for the second site etc etc

    This way analystics can distinguish between your website .

    So, if you haven't added hubpages.com to analytics it can't generate you a number.

    Go to the analytics homepage and where is says 'add new profile' follow the instructions, add hubpages and you'll get your ID.

    Hope that helps. Good Luck.

    1. SPomposello profile image79
      SPomposelloposted 5 years ago in reply to this

      Yes, that was the trick, I had to wait 24 hours to see the results. I checked and it works now. So I don't have to add extra profiles on Analytics for every hubpages article right? Just a profile for "hubpages.com" will do and it will track all the content I generate on there?

  3. thielgrad04 profile image80
    thielgrad04posted 5 years ago

    I have a question about it. I'm new, so hi all! I have the code, but I don't know where to paste it. It says right before the </head> but I don't have anything like that, even when I go to edit my text box and click on html, it only shows paragraph tags <p></p>. Where do I paste it in?!

    Thank you!!

    1. wilderness profile image96
      wildernessposted 5 years ago in reply to this

      If you already have the analytics number, go to "my account", "earnings", "affiliate settings".  Near the bottom is the section for analytics - click "configure"

      1. thielgrad04 profile image80
        thielgrad04posted 5 years ago in reply to this

        Thank you. I have the UA code in under configure, but i have to put the whole script somewhere and I'm not sure where. I've tried it in the text block of my post but nothing shows up differently, even when I sign out.  I've looked through the help files and so on and have tried what they say, but the analytic site says under tracking status that it is not installed. Am I doing something wrong?
        Thanks again.

        1. 0
          Website Examinerposted 5 years ago in reply to this

          Yes, you are doing something wrong. You do not paste code (script) into HubPages, ever. That is for websites, doesn't work here.

          You can configure Analytics for hubpages.com (written just like that, no http:// or www) - rather than your profile URL - and that should work.