jump to last post 1-31 of 31 discussions (44 posts)

Amazon link fail

  1. Jane@CM profile image60
    Jane@CMposted 8 years ago

    I read my amazon report about once every two weeks and have never had a click through.  I found a link checker in my Amazon associates page and put one of my hubs in in and get this message:

    Fail: The link above was not tagged or was not a valid Amazon link.

    Any thoughts?

  2. lrohner profile image81
    lrohnerposted 8 years ago

    How did you create the link? Does it show up as valid in your hub?

    1. Jane@CM profile image60
      Jane@CMposted 8 years agoin reply to this

      I didn't create the link, I used a link from my hub home page and tried again with a link from one of my hubs. Neither works.

      1. Fiction Teller profile image61
        Fiction Tellerposted 8 years agoin reply to this

        Jane, when you say "link from my hub home page," what do you mean?  I don't see an Amazon link in your profile page.  If there's no Amazon link on the page, it won't find one that's valid.

        I think maybe I'm not understanding something basic about what you're doing...?  Could you let us know which URL exactly you are entering?

  3. relache profile image89
    relacheposted 8 years ago

    If what you are saying is that you entered a Hub URL, well of course it's saying it's not valid, as the Amazon link checker is trying to verify a valid link back to Amazon. 

    I suggest you use Amazon capsules for listing products, as those do produce valid links.

    1. Jane@CM profile image60
      Jane@CMposted 8 years agoin reply to this

      I use a LOT of amazon capsules & not one click in 4 months...??

  4. sunforged profile image76
    sunforgedposted 8 years ago

    @jane ...its probable that you grabbed a hubpages associate link, you would have to try 3 or 4 links to be sure that you got one with your associates id in it..i am reading that your saying you grabbed a link from a capsule right?


    For everyone:

    Link Checker
    Link Checker lets you test your links to make sure they are correctly tagging to your Associate ID or one of your Tracking IDs. The only way Amazon can track a referral is through your Associate ID or Tracking ID so using the Link Checker tool is one way to help ensure that you'll be credited for all of your referral fees. To test a link, follow the two step process:
    1. Enter your link URL into the field and click the 'Load Link' button.
    2. After you see the correct page load, click the 'Check Link' button below the loaded page to check that the link tags to your Associates ID or one of your Tracking IDs.
    Learn more.

  5. sunforged profile image76
    sunforgedposted 8 years ago

    For fun I tried it, It took 4 page refreshes before i got a link that had my assoc id in it.

    But then the next 3 page refreshes had my id in it


    http://www.amazon.com/Creating-Web-Site … 2%26tag%3Dhubpages-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3D0596520972

    You can look at the link and see your id in it also

    http://www.amazon.com/Web-com-Site-Buil … 2%26tag%3Dsunforgedsid20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB000FOZCZO

  6. Jane@CM profile image60
    Jane@CMposted 8 years ago

    I did exactly what sunforged did.  I used the link checker.  I tried more hubs and still nothing.  I didn't grab a link from the capsule, I grabbed the URL from the hub itself.

    1. Lily Rose profile image86
      Lily Roseposted 8 years agoin reply to this

      Hi Jane.  I know mine is working as I've been getting a lot of sales lately, but for the heck of it I thought I'd try out the link checker - I was not aware of this.

      I entered the URL of one of my hubs with Amazon links and got a failure message.

      Then I went back to that hub, right clicked on one of the actual Amazon product links, copied the shortcut and pasted that in the link checker and got a positive response.

      You said that you grabbed the URL from the hub itself - that's not right.  Did you try it again with the URL from an actual product link?

  7. sunforged profile image76
    sunforgedposted 8 years ago
    1. sunforged profile image76
      sunforgedposted 8 years agoin reply to this

      If you hit reply you can see the source code, use the example i posted earlier to spot where our associate ids are supposed to be..youll see only the hubs id appeared  hubpages-20

  8. profile image0
    lynnechandlerposted 8 years ago

    Ok I learned something new but mine isn't working either. This could explain a lot. Hmmmm...

  9. profile image0
    lynnechandlerposted 8 years ago

    Hmmm... very confused. I get where our link is suposed to be I see it and mine shows my affiliate id but it still says it isn't linked. Now it does show clicks in the last two months so I don't have nothing at all but could it be that the products were from the keyword search and not putting in a specific product url from amazon?

    1. sunforged profile image76
      sunforgedposted 8 years agoin reply to this

      if your id is included than everything is fine, if your showing clicks in amazon than everything is fine.

      keyword vs product id isnt relevant...the capsule either is serving your link or it isnt

  10. profile image0
    lynnechandlerposted 8 years ago

    Ok thanks sunforged. I was kinda freaking out a bit because I would like to start using more amazon links in upcoming hubs. Whew back to writing.

  11. Jane@CM profile image60
    Jane@CMposted 8 years ago

    Sungforged, I emailed amazon yesterday, I had a feeling something was wrong, especially with no clicks at all.

    Hopefully this will get worked out soon, or I'll just pull all my Amazon capsules.

    Thanks Sunforged, I appreciate you backing me up on what I suspected. smile

  12. sunforged profile image76
    sunforgedposted 8 years ago

    @Jane, I would be emailing hubs...as long as your associate id is inserted under the appropriate place in affiliate settings..the issue isnt with amazon

  13. Jane@CM profile image60
    Jane@CMposted 8 years ago

    I emailed them this afternoon.  I'm sure I'll hear back next week.  smile  Until then, no more hubs built around amazon.  Guess my hopes for selling for the Christmas season are kerpunk!

  14. sunforged profile image76
    sunforgedposted 8 years ago

    I wouldnt be pessimistic, if it is a technical error, im sure they can and will fix it very,very quickly. the team always seems very speedy and responsive to technical issues.

  15. profile image0
    lynnechandlerposted 8 years ago

    Hey Jane when you set up your affiliate link did you put in your profile url as your main website you send traffic from to get your affiliate code? I'm thinking that might be the problem as it looks like you are shooting everything to hubpages url to me.

    1. Jane@CM profile image60
      Jane@CMposted 8 years agoin reply to this

      Lynne, not sure what you mean.  I have the affiliate code in the Amazon affiliate box in my affiliate setting.  Yes, I did use my profile URL when I signed up - was that bad?

  16. profile image0
    assemberposted 8 years ago

    To ask the obvious questions, did you register to be an amazon usa affiliate?

    Have you created a unique amazon tracking id?

    Have you placed your unique tracking id in the amazon affliate field in your Hub affiliate control panel ?

    1. Jane@CM profile image60
      Jane@CMposted 8 years agoin reply to this

      Yes, I have an Amazon Associate ID & it is in the Amazon affiliate setting box.

  17. profile image0
    lynnechandlerposted 8 years ago

    No that is what I did too but I'm gonna try something cause I used the one at the top in the search bar when I pull up my profile. I am going to change it to the one where we link to the profile page and see if that has any bearing on this because I still think it should say we are linked. I'll let you know if they are different in any way and what happens after I change it.

    1. prettydarkhorse profile image63
      prettydarkhorseposted 8 years agoin reply to this

      hi ms lynne, thanks and try to update us,

      and yes i have amazon links already done that...

  18. profile image0
    lynnechandlerposted 8 years ago

    It didn't change anything from my end if you click on one of my amazon links you can see my affiliate code where it is supposed to be but if you do the checker thing then it still comes back as not a valid amazon link. But it is registering the clicks because I can see the addition of my clicks when I view the report. So, I am stumped.

  19. Jane@CM profile image60
    Jane@CMposted 8 years ago

    I think I'm just screwed.

    I have 5 URLs in my amazon account, two of which I have no clue what they are for or how they got there.

    Amazon has replied to me, but since I changed my email address, we are having an issue.

    I also got turned down for a new associate id because Hubpages is not MY URL....

    Since this started, I now have 25 clicks, but now where does it show my Amazon ID, just 5 URLs.  They could at least show us our id, like Adsense does.

    1. sunforged profile image76
      sunforgedposted 8 years agoin reply to this

      Im not sure what your saying?

      5 urls in your amazon account?

      https://affiliate-program.amazon.com/gp … zon.com%2F

      Your amazon associate id and tracking id are clearly shown in the top left of your amazon associates console, the screen you directly after logging in. These are not URL's they are id..tracking codes that get added to a link (url)

      You have 25 clicks since you started this thread?

      Than everything is fine and working as it should.

      what are these 5 urls you speak of...you apply for amazon with your profile url...you wouldnt be accepted for hubpages.com because it is not your domain

      1. Jane@CM profile image60
        Jane@CMposted 8 years agoin reply to this

        Sunforged, I'm going to have to bake you cookies or muffins or something.

        Again, I'm wrong, they are tracking IDs, 5 of them. 2 from hubpages, 2 from my blog & one from a company I use to sell stuff for - not sure how that got there.

        I still don't see my id when I log in. I didn't make anything up, um, that would be a bit out of my league smile

        Going back to amazon to see if I can find my i.d., all I see are tracking codes.  I see, I'm signed in with an old webstie, that was the website I had when I worked for creative memories, it was my only website, so is that what I should put in my tracking on here?  I'm not even a cm consultant anymore.  But in hubpages my id is completely different.  I'm sure what I did when I initially signed up for amazon associates a long time ago, I used that website, as it was the only one I had.

        Hmmmm....the code in my amazon on hubpages, is one of the tracking ids from that account.

        I'm all messed up.

  20. thisisoli profile image72
    thisisoliposted 8 years ago

    Double check the Amazon Code, including the "-xx" two digits at the end.

    I make plenty of sales every week and all I had to do was enter the affiliate ID. 

    Check you are using a US amazon affiliate ID.

    If you are still having trouble then get a friend to click on one of your amazon adverts just to see if the click itself shows up in your Amazon reports.

  21. sunforged profile image76
    sunforgedposted 8 years ago
  22. sunforged profile image76
    sunforgedposted 8 years ago

    those ids, any of them, are what should be in your affiliate setting field here on hubpages.

    as you noticed they usually look something like youremail-20

    If you have a bunch of "tracking ids" thats ok, they are usually set up so you can see traffic from multiple sites.

    Its ok if your using an old id that was part of an old site, that doesnt effect your earnings.

    They are no different than the URL trackers you create here on hubpages.



    yes that is fine!

  23. Jane@CM profile image60
    Jane@CMposted 8 years ago

    I love you! In a mom sort of way.  HUGS!

  24. Jane@CM profile image60
    Jane@CMposted 8 years ago

    The link is still failing.

    I'll wait and see now that I changed to the cm associate id, if anything changes & wait to hear from Hub pages too smile

  25. Lily Rose profile image86
    Lily Roseposted 8 years ago

    @ Sunforged - out of curiosity, I clicked a bunch or product links from my hubs and on most I saw my associate id in the url, but in several I saw hubpages-20 instead of my id.  One even showed bestdealprices-20 - no clue what that is.

    I'm wondering why this would happen and does it mean if someone clicks on one of these products that's not showing my id in the link url I will not get credit for it?

  26. jaybojas profile image56
    jaybojasposted 8 years ago

    mmmmm...good thing i stopped in here.  I need all the tips in here.  Thanks to you all for all this...smile

  27. Jane@CM profile image60
    Jane@CMposted 8 years ago

    Lily, I think you gave me the missing link (no pun intended).  I'll go try that, instead of using my hub's url.

    1. Lily Rose profile image86
      Lily Roseposted 8 years agoin reply to this

      I had a feeling that no one picked up on the fact that that's what you were doing.

      I started checking the link urls for random products on a few of my hubs and I found that many contain the affiliate id hubpages-20 and not MY id.  I thought that HPs id shows up 40% of the time when it comes to AdSense; I didn't think it worked that way with Amazon, too, but I can't think of any other reason why their id would be in the link url and not mine.

      Makes me wonder how many products sales I did NOT get credit for!

      I just emailed HP asking them about it and I look forward to their response...

    2. Lily Rose profile image86
      Lily Roseposted 8 years agoin reply to this

      I'm anxiously awaiting your reply as to whether it worked for you or not...

  28. sunforged profile image76
    sunforgedposted 8 years ago

    my previous posts - that had lists of links were taken directly from Jane@cm's amazon capsules.

    On two separate occasions I refreshed her hub 10 times and copied the link out into the reply in this thread, her amazon id was never served. With or without the linkchecker that brought the issue to her attention, she certainly is not having her associate id served on her pages.

    the Hubpages id is served 40% time PERIOD *(almost), across all affiliate programs.

    The bestdeals id that you mention lily, is most likley the id of your referrer, when you refer someone to hubpages their id gets served on 10% of hubpages side of the impressions

    I havent checked in a while, so my percentage could be off...but thasts why you would see another id in your capsule on your page besides hubpages own id

  29. Lily Rose profile image86
    Lily Roseposted 8 years ago

    Thanks for the clarification, Sunforged.  Perhaps Jane still has a problem, but I realized that she was pasting her hub's url instead of the link's url into the link tracker...hope she figures out the problem.

    I thought HP's ID got 40% showing with AdSense only, not all affiliate programs - now I get it.

    As far as the other id, I have no referrals yet.  Well, actually, it shows 3 people have signed up under my tracker but zero hubs to date, so that couldn't be it...

  30. sunforged profile image76
    sunforgedposted 8 years ago

    the impression is given to the person who refers you....not a person you referred

    as for those 3 people you referred, they could never write a single hub and refer 1000's of people instead, their ids would still be served in a percentage of those referrals written hubs.

    if your referrals write a hub, their hubs will on occasion have your ids within them

  31. Jane@CM profile image60
    Jane@CMposted 8 years ago

    FYI - Hubpage team emailed me and said my Amazon is working fine...okay then.

 
working