jump to last post 1-4 of 4 discussions (7 posts)

Hubs with High HubScore But No Traffic

  1. LVM profile image54
    LVMposted 7 years ago

    I have several hubs with hubscores in the 80s yet they don't have any significant traffic.  Average is 2 pageviews a day.

  2. wrenfrost56 profile image82
    wrenfrost56posted 7 years ago

    I had that problem too, still do! I am still trying to get my head around key words and promotion. It is improving, but slooowly! Maybe a really experienced hubber will come along and help?

  3. relache profile image88
    relacheposted 7 years ago

    What are you doing to get traffic?

    "If you build it, they will come" only works in that annoying baseball movie.

    1. Pinoys profile image78
      Pinoysposted 7 years ago in reply to this

      So we need to do some additional work?

    2. LVM profile image54
      LVMposted 7 years ago in reply to this

      That is true, I'm haven't done any backlinking that I usually see being discussed here in the forums.  I need to do that then.  Thank you for another sound advice.

    3. Eaglekiwi profile image74
      Eaglekiwiposted 7 years ago in reply to this

      What do you suggest then Relache if not building?

  4. Ellen_C profile image78
    Ellen_Cposted 7 years ago

    Same things happen to me.. Strange thing is that the ones I spend the least amount of time on get the most traffic, and I have the same problem. Working harder is not giving me results lol! I will keep trying though and learning you never know what will happen. I noticed even with a few Google hits a day the AdSense was more productive because people are seeking you out. I have focused on getting the traffic from the productive places.