jump to last post 1-6 of 6 discussions (7 posts)

Problem with this new hub

  1. Kapalbility02 profile image59
    Kapalbility02posted 7 years ago

    http://hubpages.com/hub/yamaha-gigmaker-eg

    OK, so I used my own affiliate ID. The link only appeared twice, yet it says it is overly promotional. The hub contains two links to my amazon link and one link to my squidoo lens. What gives?

  2. Susana S profile image90
    Susana Sposted 7 years ago

    You've got three links that are promotional, because the squidoo lense is also yours and "self serving". You need to remove one of the links so that in total there are only two.

    Nice hub btw!

  3. Kapalbility02 profile image59
    Kapalbility02posted 7 years ago

    Thanks!

    Okay. I tweaked it already, but it still says the same thing. O_O

  4. Susana S profile image90
    Susana Sposted 7 years ago

    Hmm, well here's the FAQ: http://hubpages.com/faq/#overly_promotional

    I wonder if you have links to the same website on your other hubs? That may be the trigger.

    1. Kapalbility02 profile image59
      Kapalbility02posted 7 years ago in reply to this

      Yes, but I was promoting another product. It says per hub, not per account...

      My hub was flagged now. Didn't even give me a chance to find out what the problem was.

      EDIT: I e-mailed support. I am really in the dark here. Maybe a bug? I dunno.

  5. relache profile image86
    relacheposted 7 years ago

    If you put the Amazon links into capsules, you won't get the flag. 

    Linking to the same domain across multiple Hubs won't trigger flags, as far as I know, but it will lower your HubScores if you do it too much.

  6. flread45 profile image82
    flread45posted 7 years ago

    Use your amazon links and you won't get flagged

 
working