jump to last post 1-5 of 5 discussions (15 posts)

FIXED: "show all comments" for hidden comments acts as home

  1. cascoly profile image59
    cascolyposted 4 years ago

    when an answer has negative feedback and you unhide it, you cant read the comments - when you click on 'all comments' it just pops you to the top but doesnt displ;ay anything more

    for example

    http://poetasdsigns.hubpages.com/questi … -need-god#

    SwordofManticorE 's answer [which certainly deserves to be hidden]

    1. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      Deleted

      1. cascoly profile image59
        cascolyposted 4 years agoin reply to this

        please READ MY POST - i already clicked on 'show' - the problem is when you click on "see all X comments"  - that works for the other comments but not if the comments were hidden

    2. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      After testing on multiple machines and multiple browsers (Firefox, IE9, IE10) I was finally able to reproduce the issue using IE9 on a different Windows 7 machine.

      I have sent this to our engineering team.

      1. cascoly profile image59
        cascolyposted 4 years agoin reply to this

        thanks - i think a common source of extended problems is that the tests done internally by HP are not the same conditions that users face.

        long ago when i did consulting for tech support folks we always made sure that the computers they used were not connected in any way with the 'home' system so they could bettwer reproduce the experience of their users

        1. Matthew Meyer profile image75
          Matthew Meyerposted 4 years agoin reply to this

          I am in a different state than HubPages using DSL.  So my experience is probably pretty close to our average users'.

    3. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      This should now be working properly.

      Thanks for your patience.
      If you are still having issues, try refreshing the page and clearing browser cache.

  2. Aficionada profile image89
    Aficionadaposted 4 years ago

    Actually, Matthew, I had trouble with this on some questions too. For me, it was always the last hidden comment on the page that remained invisible. Hidden comments higher up in the answers operated as designed and planned. But at or near the bottom of the page of answers, the Show button acted like a Home button or link and caused a scrolling back to the top of the page without revealing the hidden comment at all.

    It may have been a temporary glitch that resolved itself - I haven't checked to find out.

    EDIT:   Nope, it's still occurring. Note, though, that it is not hidden answers we are discussing, but hidden comments, and the comments to the hidden answers which are linked in the OP are still operating as I described.

    ONE MORE EDIT:  If it makes any difference, I am accessing HubPages on my iPad 2; that's where I'm having the problem.

    1. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      @Aficionada

      Is this related to all questions or a subset?
      If a subset, can you provide an example?

      It looks like you might be using mobile Safari.
      We have done some recent work to better handle mobile browsers, but we are not fully there yet.

      Unfortunately, I do not have access to an iOS device right now, but can get my hands on one to do further testing later.

      You might want to consider a 3rd party browser for iOS as they allow showing the full desktop version of the site.
      I was about to suggest Firefox for iOS, but Firefox dropped iOS support a few months ago.

      I have personal experience with Dolphin:
      https://itunes.apple.com/us/app/dolphin … 12023?mt=8

      And Chrome might be useful as well.
      http://www.google.com/intl/en/chrome/br … e/ios.html

      Hope that helps!

      1. cascoly profile image59
        cascolyposted 4 years agoin reply to this

        this is on IE9 - THE MOST USED browser anywhere

        sorry for all the caps, but  this seems to be the usual HP response, dont read the original post  in full, then  first blame the user, then blame the browser -- only weeks or months later does HP admit [sometimes] ythat it was their problem in  the first place

        1. Matthew Meyer profile image75
          Matthew Meyerposted 4 years agoin reply to this

          Deleted

          1. cascoly profile image59
            cascolyposted 4 years agoin reply to this

            you replied but you didnt say you had carried out the steps to reproduce ther error have u done that yet? with what results?

  3. Aficionada profile image89
    Aficionadaposted 4 years ago

    Hi again, Matthew,

    I think that cascoly and I actually were/are describing the same problem, just in different words. I added the information about my iPad in case it would help the engineers, if this matter were passed along to them.

    I have tried to gather more information both on a desktop (using IE8) and the iPad, both signed-in to HubPages and not. A big holdup for me is the difficulty in finding answers that fit the specific criteria. I checked in the Religion and the Politics categories of Questions - assuming they would offer the widest selection of hidden answers with comments - and I narrowed my investigation to the questions that had the most answers. But I haven't found what I need, and I must now turn my attention to other matters IRL.

    I did also try to use my browser History to track down the Answers where I first noticed the problem, but I haven't had success there either.

    I'll try to keep my eyes open for further occurrences and I'll report them if I find some. But I will be busy with other matters for most of the next week, and so I may not be able to add to the conversation in any meaningful way for several days. Thanks for your replies, though.

    1. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      Thanks for the helpful information!

      Just so you are aware, when you come to this forum, we record the operating system and browser version from which a user posts.

      Please let us know for issues posted to this forum, when the browser you are using to report the issue differs from the browser/OS you used to post the report, as otherwise we assume the info reported by your browser.

      As stated above, I have forwarded this to our engineering team.

  4. Aficionada profile image89
    Aficionadaposted 4 years ago

    I'll add one more thing: as I reread my first post here, I realize that I did not describe the problem as clearly as I thought I had. It is true that my problem occurred near the bottom of the page, but that seems to be where the hidden answers were. 

    To recap: it is the collapsed comments to hidden answers that have this glitch - the link that is supposed to uncollapse the comments works like a Home button instead.

    1. Matthew Meyer profile image75
      Matthew Meyerposted 4 years agoin reply to this

      I appreciate all the helpful information you supplied.
      I don't think this should take very much to fix, so hopefully we will have the problem resolved soon!

  5. cascoly profile image59
    cascolyposted 4 years ago

    works great!  thanks for following up on this

Closed to reply
 
working