jump to last post 1-7 of 7 discussions (7 posts)

Is anyone else experiencing extreme slowness on Hubpages?

  1. FaithDream profile image80
    FaithDreamposted 6 years ago

    Is anyone else experiencing extreme slowness on Hubpages?

    It appears Hubpages is working very slowly. My hub edits are constantly in the "working" mode and moving between pages is extremely slow. IS anyone else experiencing these kinds of problems?

  2. zoey24 profile image74
    zoey24posted 6 years ago

    Yes FaithDream, since yesterday i have noticed hubpages has become very slow in loading my pictures and editing my hubs. My total views and comments etc in the account settings are also out of line, and some numbers are also missing. Hope it will all be back to normal by tomorow.

  3. tritrain profile image84
    tritrainposted 6 years ago

    It's been very slow for me, since yesterday as well.  But I had thought it was just my connection.

  4. Mark Ewbie profile image86
    Mark Ewbieposted 6 years ago

    I am becoming very slow.  My writing has dropped to a crawl and I can barely put two words together.
    Sometimes my sentences just run out of

  5. CARIBQUEEN profile image72
    CARIBQUEENposted 6 years ago

    You are not alone.  It is happening with me also. I just wait around until everything fixes itself.

  6. FaithDream profile image80
    FaithDreamposted 6 years ago

    Thanks I posted this question just to confirm it wasn't my connection. Other sites were working fine for me, except here and I was experiencing this problem since yesterday.
    It appears to have improved a little... Hopefully.
    @ Mark - too funny!!

  7. nycgrl profile image80
    nycgrlposted 6 years ago

    Ok glad I found this answer because I thought I was the only one.  It is especially slow at night (EST) I have noticed.  Lately it feels like it is getting worse.  They really should look into fixing that.  Sometimes I even have extreme slow speeds just to log into my account...very annoying.