jump to last post 1-9 of 9 discussions (10 posts)

Why is "keywords" not appearing in hubstats?

  1. thumbi7 profile image64
    thumbi7posted 5 years ago

    Why is "keywords" not appearing in hubstats?

    Earlier I could see the keywords used for searching a particular hub in the stat section.
    Now they are not seen..

  2. daisydayz profile image85
    daisydayzposted 5 years ago

    I have that problem at the moment too. Its been like that for weeks on mine though. I know they were there before but now nothing. Also my title tuner says no suggested titles, when there were a few a few weeks ago. I dont believe they can all be perfect?

    1. mary615 profile image94
      mary615posted 5 years agoin reply to this

      I used the Title Tuner frequently before, and found it helpful, too.  It is there, but like you said, it gives you no suggested titles.....

  3. Mekenzie profile image81
    Mekenzieposted 5 years ago

    I'm following this question.  I have the same thing going on with my stats.

  4. Dale Hyde profile image83
    Dale Hydeposted 5 years ago

    Same here. Am getting, "Search terms data is not currently available."

  5. mary615 profile image94
    mary615posted 5 years ago

    Yes, and if I remember correctly, you didn't have to go into "edit" to change your tags.  There was also a line that said "search words that are not in your title".  That was helpful to know, I think.  I believe this is what you are referring to, thumbi7.

  6. Patkay profile image90
    Patkayposted 5 years ago

    I think they removed that option which was very helpful. I usually used it to come up with tags, and I had seen a lot of improvement on my traffic.

  7. thumbi7 profile image64
    thumbi7posted 5 years ago

    Thanks all of you.
    It was very helpful to know which "keywords' people have used to find our hub.
    I hope that comes back again!!!

  8. Mellonyy profile image76
    Mellonyyposted 5 years ago

    Completely agree with you. It was very useful for us. I hope to see it back!

  9. pinappu profile image80
    pinappuposted 5 years ago

    Is it a bug or a new feature? Is it the new change in the system to prevent the fall of Google traffic?