Amazon capsule links

  1. nakmeister profile image86
    nakmeisterposted 5 years ago

    I've just tried linking to an Kindle book, and it can't find the product. I've tried putting the link and the ASIN number in and neither works. Has anyone else had this problem, and is there a fix?

  2. wordscribe43 profile image92
    wordscribe43posted 5 years ago

    I've had this problem numerous times.  Your best bet is to use the search by keyword option.  Highlight the exact product name, copy and paste into the search box in the Amazon capsule.  Hope this works for you.

  3. Cagsil profile image60
    Cagsilposted 5 years ago

    When I saw your thread, I opened up an unpublished hub and inserted a Amazon capsule and inputted the Kindle word as a keyword and selected 10 items and I was successful in getting them.

    I would suggest maybe using a different browser. I used Google Chrome. If that doesn't work, then maybe try clearing your browser to see if that helps.

    Other than that, you can contact staff at