jump to last post 1-3 of 3 discussions (14 posts)

Difficulty loading Amazon Ads

  1. annerivendell profile image92
    annerivendellposted 3 years ago

    Hi. I'm sorry if this has come up before, although I have searched all the help files and faq's and can't find any reference to it: I cannot load an Amazon Ad on my latest Hub. Whether I use keywords, or actually copy and paste the URL of the item, it just refuses to preview or load. I have Amazon Ads on most of my other Hubs, and I even tried waiting until this latest Hub had been "assessed" and given a score, but still no joy. Any ideas? Thank you.:-)

    1. Amy Naylor profile image81
      Amy Naylorposted 3 years agoin reply to this

      Do you have adblock? Because sometimes that can mess about with the ads you place on your hubs during the editing process.

      1. annerivendell profile image92
        annerivendellposted 3 years agoin reply to this

        Thanks Amy. I just checked and I don't seem to have it.

      2. CuAllaidh profile image84
        CuAllaidhposted 3 years agoin reply to this

        woot woot... I was having issues with this as well. So glad there was an answer here big_smile

    2. Matthew Meyer profile image76
      Matthew Meyerposted 3 years agoin reply to this

      Are you seeing a specific message that indicates the product cannot be found?
      http://hubpages.com/faq/#product-capsule-missing

      Can you find the Amazon product code?

      Here is an example product.
      www [dot] amazon [dot] com/gp/product/B00AK8SH02/

      This is the part you would want: B00AK8SH02

      Keep in mind the product must be in the US store as well.

      1. annerivendell profile image92
        annerivendellposted 3 years agoin reply to this

        Hi Matthew. Thanks for replying. The weird thing is that there is no message. Whenever I put in the entire url of the product and press "preview", it just shows that last bit (BooAK8SH02), and then nothing. If I put in keywords, again, nothing. I even tried it with different products in case the problem was with a specific one, but still nothing.

    3. Iris Draak profile image60
      Iris Draakposted 3 years ago

      You need to use the ASIN under "Product Information".  This can be found by scrolling down below the main product information.  Don't use the URL.  Good luck.

      1. annerivendell profile image92
        annerivendellposted 3 years agoin reply to this

        Hi Iris, Thank you. I've tried using the ASIN, the URL and the ISBN and none of them work.

    4. RachaelOhalloran profile image80
      RachaelOhalloranposted 3 years ago

      This happens to me on every hub I want to put an Amazon capsule. I never see it, it never previews but it's there, trust me. So, go back to your hub and put the URL of the product in and click Preview, then click SAVE.  Go to the top of your hub and Click  DONE EDITING so the changes save.

      You need to look at it from a different browser.  If you don't have the browser Firefox, download it and then launch it. It's the best browser to use on Hubpages to be able to "view" Amazon capsules, while Chrome is best browser to "write" hubs with.

      On Firefox, go to your Hubpages and sign in, then load your hub. Don't click edit, just scroll down to where you placed your Amazon hub and you'll see it there.

      If you don't want to download another browser, ask a friend who has Firefox (preferably any other browser but Chrome) ask them to go look for Amazon products on your hub. If you still don't get results, many have given up using the capsules because they only have a 50/50 chance of them working or not. 

      Good luck.

      1. annerivendell profile image92
        annerivendellposted 3 years agoin reply to this

        Hi Rachel. Thank you! I used Internet Explorer, and it works. :-)  It loaded the preview and I can see it when I press "done editing". Thank you again!

      2. That Grrl profile image73
        That Grrlposted 3 years agoin reply to this

        I noticed none of my Amazon links are showing up either. Not much point in using Amazon if they don't show up for anyone running the Chrome browser. Chrome is supposedly the one most people use these days. At least now I won't waste more time trying to fix the links.

        1. Knightmare Golem profile image95
          Knightmare Golemposted 3 years agoin reply to this

          You might want to take a look and see if the other ads are visible on the page.  If changing browsers fixes it, there might be an issue with some sort of ad blocking mechanism.  I had amazon capsules not showing up for me when I had an ad blocker I had forgot about.  The product would show up when I previewed it, but then disappeared when I finished editing.

        2. annerivendell profile image92
          annerivendellposted 3 years agoin reply to this

          Funny this is, now that the ad is loaded, it is showing up on Chrome, as are all of my Amazon ads. The problem was just with actually loading the ad in the first place.

      3. Millionaire Tips profile image93
        Millionaire Tipsposted 3 years agoin reply to this

        That happens to me too - I can't preview it, but when I click done editing, it shows up.

     
    working